blob: 85082e57999d569f5b65bc79c293653a3bca9051 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200606-05">
<title>Pound: HTTP request smuggling</title>
Pound is vulnerable to HTTP request smuggling, which could be exploited to
bypass security restrictions or poison web caches.
<product type="ebuild">pound</product>
<announced>June 07, 2006</announced>
<revised>November 24, 2006: 03</revised>
<package name="www-servers/pound" auto="yes" arch="*">
<unaffected range="ge">2.0.5</unaffected>
<unaffected range="rge">1.10</unaffected>
<unaffected range="rge">1.9.4</unaffected>
<vulnerable range="lt">2.0.5</vulnerable>
Pound is a reverse proxy, load balancer and HTTPS front-end. It allows
to distribute the load on several web servers and offers a SSL wrapper
for web servers that do not support SSL directly.
Pound fails to handle HTTP requests with conflicting "Content-Length"
and "Transfer-Encoding" headers correctly.
<impact type="low">
An attacker could exploit this vulnerability by sending HTTP requests
with specially crafted "Content-Length" and "Transfer-Encoding" headers
to bypass certain security restrictions or to poison the web proxy
There is no known workaround at this time.
All Pound users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose www-servers/pound</code>
<uri link="">CVE-2005-3751</uri>
<metadata tag="requester" timestamp="Thu, 25 May 2006 15:47:49 +0000">
<metadata tag="bugReady" timestamp="Thu, 25 May 2006 18:03:55 +0000">
<metadata tag="submitter" timestamp="Mon, 29 May 2006 16:09:23 +0000">