blob: fb9c91f87cb739f422ce5f8f0cd830de3581a2d8 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200607-04">
<title>PostgreSQL: SQL injection</title>
A flaw in the multibyte character handling allows execution of arbitrary
SQL statements.
<product type="ebuild">postgresql</product>
<announced>July 09, 2006</announced>
<revised>June 26, 2007: 03</revised>
<package name="dev-db/postgresql" auto="yes" arch="*">
<unaffected range="ge">8.0.8</unaffected>
<unaffected range="eq">7.4*</unaffected>
<vulnerable range="lt">8.0.8</vulnerable>
<vulnerable range="lt">7.4.13</vulnerable>
PostgreSQL is an open source object-relational database management
PostgreSQL contains a flaw in the string parsing routines that allows
certain backslash-escaped characters to be bypassed with some multibyte
character encodings. This vulnerability was discovered by Akio Ishida
and Yasuo Ohgaki.
<impact type="normal">
An attacker could execute arbitrary SQL statements on the PostgreSQL
server. Be aware that web applications using PostgreSQL as a database
back-end might be used to exploit this vulnerability.
There is no known workaround at this time.
All PostgreSQL users should upgrade to the latest version in the
respective branch they are using:
# emerge --sync
# emerge --ask --oneshot --verbose dev-db/postgresql</code>
Note: While a fix exists for the 7.3 branch it doesn't currently work
on Gentoo. All 7.3.x users of PostgreSQL should consider updating their
installations to the 7.4 (or higher) branch as soon as possible!
<uri link="">PostgreSQL technical information</uri>
<uri link="">CVE-2006-2313</uri>
<uri link="">CVE-2006-2314</uri>
<metadata tag="requester" timestamp="Thu, 01 Jun 2006 07:08:33 +0000">
<metadata tag="submitter" timestamp="Wed, 07 Jun 2006 19:43:38 +0000">
<metadata tag="bugReady" timestamp="Sun, 09 Jul 2006 16:30:11 +0000">