blob: 251733a201ad2ffdeba6c9841ceb2033abf4d768 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200608-20">
<title>Ruby on Rails: Several vulnerabilities</title>
Ruby on Rails has some weaknesses potentially allowing a Denial of Service
and maybe the remote execution of arbitrary Ruby scripts.
<product type="ebuild">rails</product>
<announced>August 14, 2006</announced>
<revised>December 13, 2006: 02</revised>
<package name="dev-ruby/rails" auto="yes" arch="*">
<unaffected range="ge">1.1.6</unaffected>
<vulnerable range="lt">1.1.6</vulnerable>
Ruby on Rails is an open-source web framework.
The Ruby on Rails developers have corrected some weaknesses in
action_controller/, relative to the handling of the user input and the
LOAD_PATH variable. A remote attacker could inject arbitrary entries
into the LOAD_PATH variable and alter the main Ruby on Rails process.
The security hole has only been partly solved in version 1.1.5. Version
1.1.6 now fully corrects it.
<impact type="high">
A remote attacker that would exploit these weaknesses might cause a
Denial of Service of the web framework and maybe inject arbitrary Ruby
There is no known workaround at this time.
All Ruby on Rails users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-ruby/rails-1.1.6&quot;</code>
<uri link="">Ruby on Rails original advisory (1.1.5)</uri>
<uri link="">Ruby on Rails update (1.1.6)</uri>
<uri link="">CVE-2006-4111</uri>
<uri link="">CVE-2006-4112</uri>
<metadata tag="requester" timestamp="Thu, 10 Aug 2006 07:34:02 +0000">
<metadata tag="submitter" timestamp="Thu, 10 Aug 2006 14:54:45 +0000">
<metadata tag="bugReady" timestamp="Thu, 10 Aug 2006 21:05:59 +0000">