blob: feaa26fa536586e8792705a6022241844e807072 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200608-28">
<title>PHP: Arbitary code execution</title>
PHP contains a function that, when used, could allow a remote attacker to
execute arbitrary code.
<product type="ebuild">php</product>
<announced>August 29, 2006</announced>
<revised>March 29, 2008: 05</revised>
<package name="dev-lang/php" auto="yes" arch="*">
<unaffected range="rge">4.4.3-r1</unaffected>
<unaffected range="rge">4.4.4-r4</unaffected>
<unaffected range="rge">4.4.6</unaffected>
<unaffected range="rge">4.4.7</unaffected>
<unaffected range="rge">4.4.8_pre20070816</unaffected>
<unaffected range="ge">5.1.4-r6</unaffected>
<vulnerable range="lt">5.1.4-r6</vulnerable>
PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.
The sscanf() PHP function contains an array boundary error that can be
exploited to dereference a null pointer. This can possibly allow the
bypass of the safe mode protection by executing arbitrary code.
<impact type="normal">
A remote attacker might be able to exploit this vulnerability in PHP
applications making use of the sscanf() function, potentially resulting
in the execution of arbitrary code or the execution of scripted
contents in the context of the affected site.
There is no known workaround at this time.
All PHP 4.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/php-4.4.3-r1&quot;</code>
All PHP 5.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/php-5.1.4-r6&quot;</code>
<uri link="">CVE-2006-4020</uri>
<metadata tag="requester" timestamp="Wed, 23 Aug 2006 20:16:18 +0000">
<metadata tag="bugReady" timestamp="Sat, 26 Aug 2006 14:28:36 +0000">
<metadata tag="submitter" timestamp="Sat, 26 Aug 2006 15:12:31 +0000">