blob: b827faffa5dd84662fe62b2506326e456c04bbc1 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200611-25">
<title>OpenLDAP: Denial of Service vulnerability</title>
<synopsis>
A flaw in OpenLDAP allows remote unauthenticated attackers to cause a
Denial of Service.
</synopsis>
<product type="ebuild">openldap</product>
<announced>November 28, 2006</announced>
<revised>November 28, 2006: 01</revised>
<bug>154349</bug>
<access>remote</access>
<affected>
<package name="net-nds/openldap" auto="yes" arch="*">
<unaffected range="ge">2.3.27-r3</unaffected>
<unaffected range="rge">2.2.28-r5</unaffected>
<unaffected range="rge">2.1.30-r8</unaffected>
<vulnerable range="lt">2.3.27-r3</vulnerable>
</package>
</affected>
<background>
<p>
OpenLDAP is a suite of LDAP-related applications and development tools.
</p>
</background>
<description>
<p>
Evgeny Legerov has discovered that the truncation of an incoming
authcid longer than 255 characters and ending with a space as the 255th
character will lead to an improperly computed name length. This will
trigger an assert in the libldap code.
</p>
</description>
<impact type="normal">
<p>
By sending a BIND request with a specially crafted authcid parameter to
an OpenLDAP service, a remote attacker can cause the service to crash.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time.
</p>
</workaround>
<resolution>
<p>
All OpenLDAP users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;net-nds/openldap&quot;</code>
</resolution>
<references>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-5779">CVE-2006-5779</uri>
</references>
<metadata tag="requester" timestamp="Mon, 27 Nov 2006 13:22:56 +0000">
jaervosz
</metadata>
<metadata tag="submitter" timestamp="Mon, 27 Nov 2006 16:35:57 +0000">
falco
</metadata>
<metadata tag="bugReady" timestamp="Mon, 27 Nov 2006 16:37:27 +0000">
falco
</metadata>
</glsa>