blob: bf5721604fcc0d83aa662d6e323b1d00dd0aabec [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200612-03">
<title>GnuPG: Multiple vulnerabilities</title>
GnuPG is vulnerable to a buffer overflow and an erroneous function pointer
dereference that can result in the execution of arbitrary code.
<product type="ebuild">gnupg</product>
<announced>December 10, 2006</announced>
<revised>December 10, 2006: 02</revised>
<package name="app-crypt/gnupg" auto="yes" arch="*">
<unaffected range="ge">1.4.6</unaffected>
<vulnerable range="lt">1.4.6</vulnerable>
The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite
of cryptographic software.
Hugh Warrington has reported a boundary error in GnuPG, in the
"ask_outfile_name()" function from openfile.c: the
make_printable_string() function could return a string longer than
expected. Additionally, Tavis Ormandy of the Gentoo Security Team
reported a design error in which a function pointer can be incorrectly
<impact type="normal">
A remote attacker could entice a user to interactively use GnuPG on a
crafted file and trigger the boundary error, which will result in a
buffer overflow. They could also entice a user to process a signed or
encrypted file with gpg or gpgv, possibly called through another
application like a mail client, to trigger the dereference error. Both
of these vulnerabilities would result in the execution of arbitrary
code with the permissions of the user running GnuPG. gpg-agent, gpgsm
and other tools are not affected.
There is no known workaround at this time.
All GnuPG users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;=app-crypt/gnupg-1.4*&quot;</code>
<uri link="">CVE-2006-6169</uri>
<uri link="">CVE-2006-6235</uri>
<metadata tag="requester" timestamp="Thu, 07 Dec 2006 11:29:58 +0000">
<metadata tag="submitter" timestamp="Fri, 08 Dec 2006 11:06:22 +0000">
<metadata tag="bugReady" timestamp="Sat, 09 Dec 2006 21:41:04 +0000">