blob: 87719c907ac14bcfe6c54f90959a036206ff1c30 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200705-04">
<title>Apache mod_perl: Denial of Service</title>
The mod_perl Apache module is vulnerable to a Denial of Service when
processing regular expressions.
<product type="ebuild">mod_perl</product>
<announced>May 02, 2007</announced>
<revised>May 02, 2007: 02</revised>
<package name="www-apache/mod_perl" auto="yes" arch="*">
<unaffected range="ge">2.0.3-r1</unaffected>
<unaffected range="rge">1.30</unaffected>
<vulnerable range="lt">2.0.3-r1</vulnerable>
Mod_perl is an Apache module that embeds the Perl interpreter within
the server, allowing Perl-based web-applications to be created.
Alex Solvey discovered that the "path_info" variable used in file (mod_perl 2.x) or file (mod_perl 1.x), is
not properly escaped before being processed.
<impact type="normal">
A remote attacker could send a specially crafted URL to the vulnerable
server, possibly resulting in a massive resource consumption.
There is no known workaround at this time.
All mod_perl 1.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=www-apache/mod_perl-1.30&quot;</code>
All mod_perl 2.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=www-apache/mod_perl-2.0.3-r1&quot;</code>
<uri link="">CVE-2007-1349</uri>
<metadata tag="requester" timestamp="Mon, 23 Apr 2007 19:53:36 +0000">
<metadata tag="bugReady" timestamp="Tue, 24 Apr 2007 15:28:21 +0000">
<metadata tag="submitter" timestamp="Wed, 25 Apr 2007 21:05:17 +0000">