blob: 78004619b9c6120ecac450ac7879e9da275f7227 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200705-19">
<title>PHP: Multiple vulnerabilities</title>
PHP contains several vulnerabilities including buffer and integer overflows
which could under certain conditions lead to the remote execution of
arbitrary code.
<product type="ebuild">php</product>
<announced>May 26, 2007</announced>
<revised>March 29, 2008: 02</revised>
<package name="dev-lang/php" auto="yes" arch="*">
<unaffected range="rge">4.4.7</unaffected>
<unaffected range="rge">4.4.8_pre20070816</unaffected>
<unaffected range="ge">5.2.2</unaffected>
<vulnerable range="lt">5.2.2</vulnerable>
PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.
Several vulnerabilities were found in PHP, most of them during the
Month Of PHP Bugs (MOPB) by Stefan Esser. The most severe of these
vulnerabilities are integer overflows in wbmp.c from the GD library
(CVE-2007-1001) and in the substr_compare() PHP 5 function
(CVE-2007-1375). Ilia Alshanetsky also reported a buffer overflow in
the make_http_soap_request() and in the user_filter_factory_create()
functions (CVE-2007-2510, CVE-2007-2511), and Stanislav Malyshev
discovered another buffer overflow in the bundled XMLRPC library
(CVE-2007-1864). Additionally, the session_regenerate_id() and the
array_user_key_compare() functions contain a double-free vulnerability
(CVE-2007-1484, CVE-2007-1521). Finally, there exist implementation
errors in the Zend engine, in the mb_parse_str(), the unserialize() and
the mail() functions and other elements.
<impact type="high">
Remote attackers might be able to exploit these issues in PHP
applications making use of the affected functions, potentially
resulting in the execution of arbitrary code, Denial of Service,
execution of scripted contents in the context of the affected site,
security bypass or information leak.
There is no known workaround at this time.
All PHP 5 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/php-5.2.2&quot;</code>
All PHP 4 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/php-4.4.7&quot;</code>
<uri link="">CVE-2007-1001</uri>
<uri link="">CVE-2007-1285</uri>
<uri link="">CVE-2007-1286</uri>
<uri link="">CVE-2007-1484</uri>
<uri link="">CVE-2007-1521</uri>
<uri link="">CVE-2007-1583</uri>
<uri link="">CVE-2007-1700</uri>
<uri link="">CVE-2007-1701</uri>
<uri link="">CVE-2007-1711</uri>
<uri link="">CVE-2007-1717</uri>
<uri link="">CVE-2007-1718</uri>
<uri link="">CVE-2007-1864</uri>
<uri link="">CVE-2007-1900</uri>
<uri link="">CVE-2007-2509</uri>
<uri link="">CVE-2007-2510</uri>
<uri link="">CVE-2007-2511</uri>
<metadata tag="requester" timestamp="Sun, 20 May 2007 07:27:54 +0000">
<metadata tag="bugReady" timestamp="Sun, 20 May 2007 07:28:08 +0000">
<metadata tag="submitter" timestamp="Mon, 21 May 2007 21:15:17 +0000">