blob: f50183aea1f1fbf63d469afb887a4e2a3706813d [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200711-07">
<title>Python: User-assisted execution of arbitrary code</title>
<synopsis>
Multiple integer overflow vulnerabilities have been discovered in Python,
possibly resulting in the execution of arbitrary code or a Denial of
Service.
</synopsis>
<product type="ebuild">python</product>
<announced>November 07, 2007</announced>
<revised>November 07, 2007: 01</revised>
<bug>192876</bug>
<access>remote</access>
<affected>
<package name="dev-lang/python" auto="yes" arch="*">
<unaffected range="rge">2.3.6-r3</unaffected>
<unaffected range="ge">2.4.4-r6</unaffected>
<vulnerable range="lt">2.4.4-r6</vulnerable>
</package>
</affected>
<background>
<p>
Python is an interpreted, interactive, object-oriented programming
language.
</p>
</background>
<description>
<p>
Slythers Bro discovered multiple integer overflows in the imageop
module, one of them in the tovideo() method, in various locations in
files imageop.c, rbgimgmodule.c, and also in other files.
</p>
</description>
<impact type="normal">
<p>
A remote attacker could entice a user to process specially crafted
images with an application using the Python imageop module, resulting
in the execution of arbitrary code with the privileges of the user
running the application, or a Denial of Service. Note that this
vulnerability may or may not be exploitable, depending on the
application using the module.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time.
</p>
</workaround>
<resolution>
<p>
All Python 2.3.x users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/python-2.3.6-r3&quot;</code>
<p>
All Python 2.4.x users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/python-2.4.4-r6&quot;</code>
</resolution>
<references>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4965">CVE-2007-4965</uri>
</references>
<metadata tag="requester" timestamp="Sat, 27 Oct 2007 13:38:30 +0000">
rbu
</metadata>
<metadata tag="submitter" timestamp="Thu, 01 Nov 2007 20:41:20 +0000">
p-y
</metadata>
<metadata tag="bugReady" timestamp="Thu, 01 Nov 2007 20:41:27 +0000">
p-y
</metadata>
</glsa>