blob: c2bfd4b948785a3d548bf5a6bfd321876d18a7c9 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200712-25">
<title>OpenOffice.org: User-assisted arbitrary code execution</title>
<synopsis>
An unspecified vulnerability has been reported in OpenOffice.org, possibly
allowing for the execution of arbitrary code.
</synopsis>
<product type="ebuild">openoffice openoffice-bin hsqldb</product>
<announced>December 30, 2007</announced>
<revised>December 30, 2007: 01</revised>
<bug>200771</bug>
<bug>201799</bug>
<access>remote</access>
<affected>
<package name="app-office/openoffice" auto="yes" arch="*">
<unaffected range="ge">2.3.1</unaffected>
<vulnerable range="lt">2.3.1</vulnerable>
</package>
<package name="app-office/openoffice-bin" auto="yes" arch="*">
<unaffected range="ge">2.3.1</unaffected>
<vulnerable range="lt">2.3.1</vulnerable>
</package>
<package name="dev-db/hsqldb" auto="yes" arch="*">
<unaffected range="ge">1.8.0.9</unaffected>
<vulnerable range="lt">1.8.0.9</vulnerable>
</package>
</affected>
<background>
<p>
OpenOffice.org is an open source office productivity suite, including
word processing, spreadsheet, presentation, drawing, data charting,
formula editing, and file conversion facilities.
</p>
</background>
<description>
<p>
The HSQLDB engine, as used in Openoffice.org, does not properly enforce
restrictions to SQL statements.
</p>
</description>
<impact type="normal">
<p>
A remote attacker could entice a user to open a specially crafted
document, possibly resulting in the remote execution of arbitrary Java
code with the privileges of the user running OpenOffice.org.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time.
</p>
</workaround>
<resolution>
<p>
All OpenOffice.org users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=app-office/openoffice-2.3.1&quot;</code>
<p>
All OpenOffice.org binary users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=app-office/openoffice-bin-2.3.1&quot;</code>
<p>
All HSQLDB users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-db/hsqldb-1.8.0.9&quot;</code>
</resolution>
<references>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4575">CVE-2007-4575</uri>
</references>
<metadata tag="requester" timestamp="Sat, 08 Dec 2007 23:31:31 +0000">
p-y
</metadata>
<metadata tag="bugReady" timestamp="Sat, 08 Dec 2007 23:31:39 +0000">
p-y
</metadata>
<metadata tag="submitter" timestamp="Sun, 09 Dec 2007 00:15:00 +0000">
p-y
</metadata>
</glsa>