blob: c1739da28443d5c1cb35554ea37234ff4c49f141 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200802-10">
<title>Python: PCRE Integer overflow</title>
A vulnerability within Python's copy of PCRE might lead to the execution of
arbitrary code.
<product type="ebuild">python</product>
<announced>February 23, 2008</announced>
<revised>February 23, 2008: 01</revised>
<package name="dev-lang/python" auto="yes" arch="*">
<unaffected range="ge">2.3.6-r4</unaffected>
<vulnerable range="lt">2.3.6-r4</vulnerable>
Python is an interpreted, interactive, object-oriented programming
Python 2.3 includes a copy of PCRE which is vulnerable to an integer
overflow vulnerability, leading to a buffer overflow.
<impact type="normal">
An attacker could exploit the vulnerability by tricking a vulnerable
Python application to compile a regular expressions, which could
possibly lead to the execution of arbitrary code, a Denial of Service
or the disclosure of sensitive information.
There is no known workaround at this time.
All Python 2.3 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-lang/python-2.3.6-r4&quot;</code>
<uri link="">CVE-2006-7228</uri>
<uri link="/security/en/glsa/glsa-200711-30.xml">GLSA 200711-30</uri>
<metadata tag="requester" timestamp="Mon, 07 Jan 2008 19:00:53 +0000">
<metadata tag="bugReady" timestamp="Mon, 28 Jan 2008 18:01:42 +0000">
<metadata tag="submitter" timestamp="Mon, 18 Feb 2008 22:37:11 +0000">