blob: e9a08c9bcb320f191bb3b276ea3c73c6e6abdea4 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200803-18">
<title>Cacti: Multiple vulnerabilities</title>
Multiple vulnerabilities were discovered in Cacti.
<product type="ebuild">cacti</product>
<announced>March 10, 2008</announced>
<revised>May 28, 2009: 02</revised>
<package name="net-analyzer/cacti" auto="yes" arch="*">
<unaffected range="ge">0.8.7b</unaffected>
<unaffected range="rge">0.8.6j-r8</unaffected>
<vulnerable range="lt">0.8.7b</vulnerable>
Cacti is a web-based network graphing and reporting tool.
The following inputs are not properly sanitized before being processed:
<ul><li>"view_type" parameter in the file graph.php, "filter" parameter
in the file graph_view.php, "action" and "login_username" parameters in
the file index.php (CVE-2008-0783).</li>
<li>"local_graph_id" parameter in the file graph.php
<li>"graph_list" parameter in the file graph_view.php, "leaf_id" and
"id" parameters in the file tree.php, "local_graph_id" in the file
graph_xport.php (CVE-2008-0785).</li>
Furthermore, CRLF injection attack are possible via unspecified vectors
<impact type="normal">
A remote attacker could exploit these vulnerabilities, leading to path
disclosure, Cross-Site Scripting attacks, SQL injection, and HTTP
response splitting.
There is no known workaround at this time.
All Cacti users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=net-analyzer/cacti-0.8.7b&quot;</code>
<uri link="">CVE-2008-0783</uri>
<uri link="">CVE-2008-0784</uri>
<uri link="">CVE-2008-0785</uri>
<uri link="">CVE-2008-0786</uri>
<metadata tag="requester" timestamp="Mon, 25 Feb 2008 22:16:20 +0000">
<metadata tag="submitter" timestamp="Fri, 07 Mar 2008 23:16:40 +0000">
<metadata tag="bugReady" timestamp="Fri, 07 Mar 2008 23:16:51 +0000">