blob: 8758b5aac12b377e8282745d04602f900e8b0b15 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200803-24">
<title>PCRE: Buffer overflow</title>
A buffer overflow vulnerability has been discovered in PCRE, allowing for
the execution of arbitrary code and Denial of Service.
<product type="ebuild">libpcre glib</product>
<announced>March 17, 2008</announced>
<revised>March 17, 2008: 02</revised>
<package name="dev-libs/libpcre" auto="yes" arch="*">
<unaffected range="ge">7.6-r1</unaffected>
<vulnerable range="lt">7.6-r1</vulnerable>
<package name="dev-libs/glib" auto="yes" arch="*">
<unaffected range="ge">2.14.6</unaffected>
<unaffected range="lt">2.14.0</unaffected>
<vulnerable range="lt">2.14.6</vulnerable>
PCRE is a Perl-compatible regular expression library. GLib includes a
copy of PCRE.
PCRE contains a buffer overflow vulnerability when processing a
character class containing a very large number of characters with
codepoints greater than 255.
<impact type="high">
A remote attacker could exploit this vulnerability by sending a
specially crafted regular expression to an application making use of
the PCRE library, which could possibly lead to the execution of
arbitrary code or a Denial of Service.
There is no known workaround at this time.
All PCRE users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-libs/libpcre-7.6-r1&quot;</code>
All GLib users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-libs/glib-2.14.6&quot;</code>
<uri link="">CVE-2008-0674</uri>
<metadata tag="requester" timestamp="Tue, 26 Feb 2008 20:45:26 +0000">
<metadata tag="bugReady" timestamp="Sat, 01 Mar 2008 06:12:22 +0000">
<metadata tag="submitter" timestamp="Wed, 05 Mar 2008 14:06:55 +0000">