blob: 5cde3bb17b063f87d896342f8da98fe8db827435 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200804-30">
<title>KDE start_kdeinit: Multiple vulnerabilities</title>
Multiple vulnerabilities in start_kdeinit could possibly allow a local
attacker to execute arbitrary code with root privileges.
<product type="ebuild">kdelibs</product>
<announced>April 29, 2008</announced>
<revised>April 08, 2009: 02</revised>
<package name="kde-base/kdelibs" auto="yes" arch="*">
<unaffected range="rge">3.5.8-r4</unaffected>
<unaffected range="rge">3.5.9-r3</unaffected>
<unaffected range="gt">4.0</unaffected>
<unaffected range="lt">3.5.5</unaffected>
<unaffected range="rge">3.5.10-r2</unaffected>
<vulnerable range="lt">4.0</vulnerable>
KDE is a feature-rich graphical desktop environment for Linux and
Unix-like operating systems. start_kdeinit is a wrapper for kdeinit.
Vulnerabilities have been reported in the processing of user-controlled
data by start_kdeinit, which is setuid root by default.
<impact type="high">
A local attacker could possibly execute arbitrary code with root
privileges, cause a Denial of Service or send Unix signals to other
processes, when start_kdeinit is setuid root.
There is no known workaround at this time.
All kdelibs users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=kde-base/kdelibs-3.5.8-r4&quot;</code>
<uri link="">CVE-2008-1671</uri>
<metadata tag="submitter" timestamp="Thu, 24 Apr 2008 09:52:59 +0000">
<metadata tag="bugReady" timestamp="Mon, 28 Apr 2008 13:20:59 +0000">