blob: d7647ce28f98be499cfdba0a4701feef35d72674 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200805-20">
<title>GnuTLS: Execution of arbitrary code</title>
Multiple vulnerabilities might allow for the execution of arbitrary code in
daemons using GnuTLS.
<product type="ebuild">gnutls</product>
<announced>May 21, 2008</announced>
<revised>May 21, 2008: 01</revised>
<package name="net-libs/gnutls" auto="yes" arch="*">
<unaffected range="ge">2.2.5</unaffected>
<vulnerable range="lt">2.2.5</vulnerable>
GnuTLS is an implementation of Secure Sockets Layer (SSL) 3.0 and
Transport Layer Security (TLS) 1.0, 1.1 and 1.2.
Ossi Herrala and Jukka Taimisto of Codenomicon reported three
vulnerabilities in libgnutls of GnuTLS:
"Client Hello" messages containing an invalid server name can lead to a
buffer overflow when evaluating "Security Parameters" (CVE-2008-1948).
Multiple "Client Hello" messages can lead to a NULL pointer dereference
A TLS handshake including an encrypted "Client Hello" message and an
invalid record length could lead to a buffer overread (CVE-2008-1950).
<impact type="high">
Unauthenticated remote attackers could exploit these vulnerabilities to
cause Denial of Service conditions in daemons using GnuTLS. The first
vulnerability (CVE-2008-1948) might allow for the execution of
arbitrary code with the privileges of the daemon handling incoming TLS
There is no known workaround at this time.
All GnuTLS users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=net-libs/gnutls-2.2.5&quot;</code>
<uri link="">CVE-2008-1948</uri>
<uri link="">CVE-2008-1949</uri>
<uri link="">CVE-2008-1950</uri>
<metadata tag="submitter" timestamp="Tue, 20 May 2008 16:44:10 +0000">
<metadata tag="bugReady" timestamp="Wed, 21 May 2008 16:32:55 +0000">