blob: 6e490c092672d00d70b3f19fc204fa12080d7a87 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200807-03">
<title>PCRE: Buffer overflow</title>
A buffer overflow vulnerability has been discovered in PCRE, allowing for
the execution of arbitrary code and a Denial of Service.
<product type="ebuild">libpcre glib</product>
<announced>July 07, 2008</announced>
<revised>July 07, 2008: 01</revised>
<package name="dev-libs/libpcre" auto="yes" arch="*">
<unaffected range="ge">7.7-r1</unaffected>
<vulnerable range="lt">7.7-r1</vulnerable>
<package name="dev-libs/glib" auto="yes" arch="*">
<unaffected range="ge">2.16.3-r1</unaffected>
<unaffected range="lt">2.14.0</unaffected>
<vulnerable range="lt">2.16.3-r1</vulnerable>
PCRE is a Perl-compatible regular expression library. GLib includes a
copy of PCRE.
Tavis Ormandy of the Google Security team reported a heap-based buffer
overflow when compiling regular expression patterns containing
"Internal Option Settings" such as "<i>(?i)</i>".
<impact type="high">
A remote attacker could exploit this vulnerability by sending a
specially crafted regular expression to an application making use of
the PCRE library, which could possibly lead to the execution of
arbitrary code or a Denial of Service.
There is no known workaround at this time.
All PCRE users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-libs/libpcre-7.7-r1&quot;</code>
All GLib users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-libs/glib-2.16.3-r1&quot;</code>
<uri link="">CVE-2008-2371</uri>
<metadata tag="submitter" timestamp="Mon, 07 Jul 2008 00:02:02 +0000">
<metadata tag="bugReady" timestamp="Mon, 07 Jul 2008 00:02:22 +0000">