blob: 6e490c092672d00d70b3f19fc204fa12080d7a87 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200807-03">
<title>PCRE: Buffer overflow</title>
<synopsis>
A buffer overflow vulnerability has been discovered in PCRE, allowing for
the execution of arbitrary code and a Denial of Service.
</synopsis>
<product type="ebuild">libpcre glib</product>
<announced>July 07, 2008</announced>
<revised>July 07, 2008: 01</revised>
<bug>228091</bug>
<bug>230039</bug>
<access>remote</access>
<affected>
<package name="dev-libs/libpcre" auto="yes" arch="*">
<unaffected range="ge">7.7-r1</unaffected>
<vulnerable range="lt">7.7-r1</vulnerable>
</package>
<package name="dev-libs/glib" auto="yes" arch="*">
<unaffected range="ge">2.16.3-r1</unaffected>
<unaffected range="lt">2.14.0</unaffected>
<vulnerable range="lt">2.16.3-r1</vulnerable>
</package>
</affected>
<background>
<p>
PCRE is a Perl-compatible regular expression library. GLib includes a
copy of PCRE.
</p>
</background>
<description>
<p>
Tavis Ormandy of the Google Security team reported a heap-based buffer
overflow when compiling regular expression patterns containing
"Internal Option Settings" such as "<i>(?i)</i>".
</p>
</description>
<impact type="high">
<p>
A remote attacker could exploit this vulnerability by sending a
specially crafted regular expression to an application making use of
the PCRE library, which could possibly lead to the execution of
arbitrary code or a Denial of Service.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time.
</p>
</workaround>
<resolution>
<p>
All PCRE users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-libs/libpcre-7.7-r1&quot;</code>
<p>
All GLib users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-libs/glib-2.16.3-r1&quot;</code>
</resolution>
<references>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-2371">CVE-2008-2371</uri>
</references>
<metadata tag="submitter" timestamp="Mon, 07 Jul 2008 00:02:02 +0000">
rbu
</metadata>
<metadata tag="bugReady" timestamp="Mon, 07 Jul 2008 00:02:22 +0000">
rbu
</metadata>
</glsa>