blob: 3dc53098e93588884f686688d2f8db93d389bbe0 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200809-09">
<title>Postfix: Denial of Service</title>
A memory leak in Postfix might allow local users to cause a Denial of
<product type="ebuild">postfix</product>
<announced>September 19, 2008</announced>
<revised>September 19, 2008: 01</revised>
<package name="mail-mta/postfix" auto="yes" arch="*">
<unaffected range="ge">2.4.9</unaffected>
<unaffected range="ge">2.5.5</unaffected>
<vulnerable range="lt">2.4.9</vulnerable>
<vulnerable range="lt">2.5.5</vulnerable>
Postfix is Wietse Venema's mailer that attempts to be fast, easy to
administer, and secure, as an alternative to the widely-used Sendmail
It has been discovered than Postfix leaks an epoll file descriptor when
executing external commands, e.g. user-controlled $HOME/.forward or
$HOME/.procmailrc files. NOTE: This vulnerability only concerns Postfix
instances running on Linux 2.6 kernels.
<impact type="normal">
A local attacker could exploit this vulnerability to reduce the
performance of Postfix, and possibly trigger an assertion, resulting in
a Denial of Service.
Allow only trusted users to control delivery to non-Postfix commands.
All Postfix 2.4 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=mail-mta/postfix-2.4.9&quot;</code>
All Postfix 2.5 users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=mail-mta/postfix-2.5.5&quot;</code>
<uri link="">CVE-2008-3889</uri>
<metadata tag="requester" timestamp="Wed, 03 Sep 2008 20:58:07 +0000">
<metadata tag="submitter" timestamp="Mon, 08 Sep 2008 18:33:40 +0000">
<metadata tag="bugReady" timestamp="Mon, 08 Sep 2008 18:33:49 +0000">