blob: ff007ad1a273dffc21c79c3536d63610f37f7282 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200812-15">
<title>POV-Ray: User-assisted execution of arbitrary code</title>
POV-Ray includes a version of libpng that might allow for the execution of
arbitrary code when reading a specially crafted PNG file
<product type="ebuild">povray</product>
<announced>December 14, 2008</announced>
<revised>December 14, 2008: 01</revised>
<package name="media-gfx/povray" auto="yes" arch="*">
<unaffected range="ge">3.6.1-r4</unaffected>
<vulnerable range="lt">3.6.1-r4</vulnerable>
POV-Ray is a well known open-source ray tracer.
POV-Ray uses a statically linked copy of libpng to view and output PNG
files. The version shipped with POV-Ray is vulnerable to CVE-2008-3964,
CVE-2008-1382, CVE-2006-3334, CVE-2006-0481, CVE-2004-0768. A bug in
POV-Ray's build system caused it to load the old version when your
installed copy of libpng was >=media-libs/libpng-1.2.10.
<impact type="normal">
An attacker could entice a user to load a specially crafted PNG file as
a texture, resulting in the execution of arbitrary code with the
permissions of the user running the application.
There is no known workaround at this time.
All POV-Ray users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=media-gfx/povray-3.6.1-r4&quot;</code>
<uri link="">CVE-2004-0768</uri>
<uri link="">CVE-2006-0481</uri>
<uri link="">CVE-2006-3334</uri>
<uri link="">CVE-2008-1382</uri>
<uri link="">CVE-2008-3964</uri>
<metadata tag="requester" timestamp="Thu, 04 Dec 2008 23:06:51 +0000">
<metadata tag="submitter" timestamp="Sat, 06 Dec 2008 15:52:40 +0000">
<metadata tag="bugReady" timestamp="Thu, 11 Dec 2008 20:06:51 +0000">