blob: ff007ad1a273dffc21c79c3536d63610f37f7282 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200812-15">
<title>POV-Ray: User-assisted execution of arbitrary code</title>
<synopsis>
POV-Ray includes a version of libpng that might allow for the execution of
arbitrary code when reading a specially crafted PNG file
</synopsis>
<product type="ebuild">povray</product>
<announced>December 14, 2008</announced>
<revised>December 14, 2008: 01</revised>
<bug>153538</bug>
<access>local</access>
<affected>
<package name="media-gfx/povray" auto="yes" arch="*">
<unaffected range="ge">3.6.1-r4</unaffected>
<vulnerable range="lt">3.6.1-r4</vulnerable>
</package>
</affected>
<background>
<p>
POV-Ray is a well known open-source ray tracer.
</p>
</background>
<description>
<p>
POV-Ray uses a statically linked copy of libpng to view and output PNG
files. The version shipped with POV-Ray is vulnerable to CVE-2008-3964,
CVE-2008-1382, CVE-2006-3334, CVE-2006-0481, CVE-2004-0768. A bug in
POV-Ray's build system caused it to load the old version when your
installed copy of libpng was >=media-libs/libpng-1.2.10.
</p>
</description>
<impact type="normal">
<p>
An attacker could entice a user to load a specially crafted PNG file as
a texture, resulting in the execution of arbitrary code with the
permissions of the user running the application.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time.
</p>
</workaround>
<resolution>
<p>
All POV-Ray users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=media-gfx/povray-3.6.1-r4&quot;</code>
</resolution>
<references>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0768">CVE-2004-0768</uri>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0481">CVE-2006-0481</uri>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3334">CVE-2006-3334</uri>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1382">CVE-2008-1382</uri>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-3964">CVE-2008-3964</uri>
</references>
<metadata tag="requester" timestamp="Thu, 04 Dec 2008 23:06:51 +0000">
mabi
</metadata>
<metadata tag="submitter" timestamp="Sat, 06 Dec 2008 15:52:40 +0000">
mabi
</metadata>
<metadata tag="bugReady" timestamp="Thu, 11 Dec 2008 20:06:51 +0000">
p-y
</metadata>
</glsa>