blob: 8b0d519649bb8c47fa0a3da40225ba828e43623d [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200901-10">
<title>GnuTLS: Certificate validation error</title>
A certificate validation error in GnuTLS might allow for spoofing attacks.
<product type="ebuild">gnutls</product>
<announced>January 14, 2009</announced>
<revised>January 14, 2009: 01</revised>
<package name="net-libs/gnutls" auto="yes" arch="*">
<unaffected range="ge">2.4.1-r2</unaffected>
<vulnerable range="lt">2.4.1-r2</vulnerable>
GnuTLS is an open-source implementation of TLS 1.0 and SSL 3.0.
Martin von Gagern reported that the _gnutls_x509_verify_certificate()
function in lib/x509/verify.c trusts certificate chains in which the
last certificate is an arbitrary trusted, self-signed certificate.
<impact type="normal">
A remote attacker could exploit this vulnerability and spoof arbitrary
names to conduct Man-In-The-Middle attacks and intercept sensitive
There is no known workaround at this time.
All GnuTLS users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=net-libs/gnutls-2.4.1-r2&quot;</code>
<uri link="">CVE-2008-4989</uri>
<metadata tag="requester" timestamp="Sun, 30 Nov 2008 19:06:26 +0000">
<metadata tag="submitter" timestamp="Sat, 10 Jan 2009 23:37:58 +0000">
<metadata tag="bugReady" timestamp="Sat, 10 Jan 2009 23:38:09 +0000">