blob: 9be8336c40a51dc9d0aacdf76c18c76fe211f40b [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<glsa id="200908-01">
<title>OpenSC: Multiple vulnerabilities</title>
Multiple vulnerabilities were found in OpenSC.
<product type="ebuild">opensc</product>
<announced>August 01, 2009</announced>
<revised>August 01, 2009: 01</revised>
<package name="dev-libs/opensc" auto="yes" arch="*">
<unaffected range="ge">0.11.8</unaffected>
<vulnerable range="lt">0.11.8</vulnerable>
OpenSC provides a set of libraries and utilities to access smart cards.
Multiple vulnerabilities were found in OpenSC:
<li>b.badrignans discovered that OpenSC incorrectly initialises private
data objects (CVE-2009-0368).</li>
<li>Miquel Comas Marti discovered
that src/tools/pkcs11-tool.c in pkcs11-tool in OpenSC 0.11.7, when used
with unspecified third-party PKCS#11 modules, generates RSA keys with
incorrect public exponents (CVE-2009-1603).</li>
<impact type="normal">
The first vulnerabilty allows physically proximate attackers to bypass
intended PIN requirements and read private data objects. The second
vulnerability allows attackers to read the cleartext form of messages
that were intended to be encrypted.
NOTE: Smart cards which were initialised using an affected version of
OpenSC need to be modified or re-initialised. See the vendor's advisory
for details.
There is no known workaround at this time.
All OpenSC users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-libs/opensc-0.11.8&quot;</code>
<uri link="">CVE-2009-0368</uri>
<uri link="">CVE-2009-1603</uri>
<uri link="">OpenSC Security Advisory</uri>
<metadata tag="requester" timestamp="Wed, 24 Jun 2009 16:49:20 +0000">
<metadata tag="submitter" timestamp="Wed, 29 Jul 2009 17:15:19 +0000">
<metadata tag="bugReady" timestamp="Sat, 01 Aug 2009 12:35:17 +0000">