blob: bb3d37e9d2d45c5a1967b5bc67d6ade22b238bf8 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="200909-03">
<title>Apache Portable Runtime, APR Utility Library: Execution of arbitrary code</title>
<synopsis>
Multiple integer overflows in the Apache Portable Runtime and its Utility
Library might allow for the remote execution of arbitrary code.
</synopsis>
<product type="ebuild">apr apr-util</product>
<announced>September 09, 2009</announced>
<revised>September 09, 2009: 01</revised>
<bug>280514</bug>
<access>remote</access>
<affected>
<package name="dev-libs/apr" auto="yes" arch="*">
<unaffected range="ge">1.3.8</unaffected>
<vulnerable range="lt">1.3.8</vulnerable>
</package>
<package name="dev-libs/apr-util" auto="yes" arch="*">
<unaffected range="ge">1.3.9</unaffected>
<vulnerable range="lt">1.3.9</vulnerable>
</package>
</affected>
<background>
<p>
The Apache Portable Runtime (aka APR) provides a set of APIs for
creating platform-independent applications. The Apache Portable Runtime
Utility Library (aka APR-Util) provides an interface to functionality
such as XML parsing, string matching and databases connections.
</p>
</background>
<description>
<p>
Matt Lewis reported multiple Integer overflows in the apr_rmm_malloc(),
apr_rmm_calloc(), and apr_rmm_realloc() functions in misc/apr_rmm.c of
APR-Util and in memory/unix/apr_pools.c of APR, both occurring when
aligning memory blocks.
</p>
</description>
<impact type="normal">
<p>
A remote attacker could entice a user to connect to a malicious server
with software that uses the APR or act as a malicious client to a
server that uses the APR (such as Subversion or Apache servers),
possibly resulting in the execution of arbitrary code with the
privileges of the user running the application.
</p>
</impact>
<workaround>
<p>
There is no known workaround at this time.
</p>
</workaround>
<resolution>
<p>
All Apache Portable Runtime users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-libs/apr-1.3.8&quot;</code>
<p>
All APR Utility Library users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=dev-libs/apr-util-1.3.9&quot;</code>
</resolution>
<references>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-2412">CVE-2009-2412</uri>
</references>
<metadata tag="requester" timestamp="Thu, 06 Aug 2009 13:32:21 +0000">
a3li
</metadata>
<metadata tag="submitter" timestamp="Thu, 06 Aug 2009 13:46:29 +0000">
a3li
</metadata>
<metadata tag="bugReady" timestamp="Mon, 24 Aug 2009 20:40:13 +0000">
a3li
</metadata>
</glsa>