blob: 8fc1176660152f8e4cbd18095cd935eb2c4effe3 [file] [log] [blame]
<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201001-05">
<title>net-snmp: Authorization bypass</title>
<synopsis>
A remote attacker can bypass the tcp-wrappers client authorization in
net-snmp.
</synopsis>
<product type="ebuild">net-snmp</product>
<announced>January 13, 2010</announced>
<revised>January 13, 2010: 01</revised>
<bug>250429</bug>
<access>remote</access>
<affected>
<package name="net-analyzer/net-snmp" auto="yes" arch="*">
<unaffected range="ge">5.4.2.1-r1</unaffected>
<vulnerable range="lt">5.4.2.1-r1</vulnerable>
</package>
</affected>
<background>
<p>
net-snmp bundles software for generating and retrieving SNMP data.
</p>
</background>
<description>
<p>
The netsnmp_udp_fmtaddr() function (snmplib/snmpUDPDomain.c), when
using TCP wrappers for client authorization, does not properly parse
hosts.allow rules.
</p>
</description>
<impact type="normal">
<p>
A remote, unauthenticated attacker could bypass the ACL filtering,
possibly resulting in the execution of arbitrary SNMP queries.
</p>
</impact>
<workaround>
<p>
If possible, protect net-snmp with custom iptables rules:
</p>
<code>
iptables -s [client] -d [host] -p udp --dport 161 -j ACCEPT
iptables -s 0.0.0.0/0 -d [host] -p udp --dport 161 -j DROP</code>
</workaround>
<resolution>
<p>
All net-snmp users should upgrade to the latest version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose &quot;&gt;=net-analyzer/net-snmp-5.4.2.1-r1&quot;</code>
</resolution>
<references>
<uri link="http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-6123">CVE-2008-6123</uri>
</references>
<metadata tag="requester" timestamp="Mon, 28 Sep 2009 18:16:15 +0000">
craig
</metadata>
<metadata tag="submitter" timestamp="Tue, 05 Jan 2010 21:17:32 +0000">
craig
</metadata>
<metadata tag="bugReady" timestamp="Sun, 10 Jan 2010 19:40:57 +0000">
craig
</metadata>
</glsa>