blob: 93b517a2f6b50085d582f2cc74bb73398f31b3eb [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201110-01">
<title>OpenSSL: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities were found in OpenSSL, allowing for the
execution of arbitrary code and other attacks.
</synopsis>
<product type="ebuild">openssl</product>
<announced>October 09, 2011</announced>
<revised>June 06, 2015: 13</revised>
<bug>303739</bug>
<bug>308011</bug>
<bug>322575</bug>
<bug>332027</bug>
<bug>345767</bug>
<bug>347623</bug>
<bug>354139</bug>
<bug>382069</bug>
<access>local, remote</access>
<affected>
<package name="dev-libs/openssl" auto="yes" arch="*">
<unaffected range="ge">1.0.0e</unaffected>
<unaffected range="rge">0.9.8r</unaffected>
<unaffected range="rge">0.9.8s</unaffected>
<unaffected range="rge">0.9.8t</unaffected>
<unaffected range="rge">0.9.8u</unaffected>
<unaffected range="rge">0.9.8v</unaffected>
<unaffected range="rge">0.9.8w</unaffected>
<unaffected range="rge">0.9.8x</unaffected>
<unaffected range="rge">0.9.8y</unaffected>
<unaffected range="rge">0.9.8z_p1</unaffected>
<unaffected range="rge">0.9.8z_p2</unaffected>
<unaffected range="rge">0.9.8z_p3</unaffected>
<unaffected range="rge">0.9.8z_p4</unaffected>
<unaffected range="rge">0.9.8z_p5</unaffected>
<unaffected range="rge">0.9.8z_p6</unaffected>
<unaffected range="rge">0.9.8z_p7</unaffected>
<unaffected range="rge">0.9.8z_p8</unaffected>
<unaffected range="rge">0.9.8z_p9</unaffected>
<unaffected range="rge">0.9.8z_p10</unaffected>
<unaffected range="rge">0.9.8z_p11</unaffected>
<unaffected range="rge">0.9.8z_p12</unaffected>
<unaffected range="rge">0.9.8z_p13</unaffected>
<unaffected range="rge">0.9.8z_p14</unaffected>
<unaffected range="rge">0.9.8z_p15</unaffected>
<vulnerable range="lt">1.0.0e</vulnerable>
</package>
</affected>
<background>
<p>OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.
</p>
</background>
<description>
<p>Multiple vulnerabilities have been discovered in OpenSSL. Please review
the CVE identifiers referenced below for details.
</p>
</description>
<impact type="high">
<p>A context-dependent attacker could cause a Denial of Service, possibly
execute arbitrary code, bypass intended key requirements, force the
downgrade to unintended ciphers, bypass the need for knowledge of shared
secrets and successfully authenticate, bypass CRL validation, or obtain
sensitive information in applications that use OpenSSL.
</p>
</impact>
<workaround>
<p>There is no known workaround at this time.</p>
</workaround>
<resolution>
<p>All OpenSSL users should upgrade to the latest version:</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-libs/openssl-1.0.0e"
</code>
<p>NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since September 17, 2011. It is likely that your system is
already no longer affected by most of these issues.
</p>
</resolution>
<references>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3245">CVE-2009-3245</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-4355">CVE-2009-4355</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0433">CVE-2010-0433</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0740">CVE-2010-0740</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0742">CVE-2010-0742</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-1633">CVE-2010-1633</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-2939">CVE-2010-2939</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-3864">CVE-2010-3864</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-4180">CVE-2010-4180</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-4252">CVE-2010-4252</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-0014">CVE-2011-0014</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3207">CVE-2011-3207</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-3210">CVE-2011-3210</uri>
</references>
<metadata tag="requester" timestamp="Fri, 07 Oct 2011 23:38:03 +0000">craig</metadata>
<metadata tag="submitter" timestamp="Sat, 06 Jun 2015 23:06:31 +0000">
keytoaster
</metadata>
</glsa>