blob: e025ccad6af67456fc8feb10f86c743e2908fac9 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201110-15">
<title>GnuPG: User-assisted execution of arbitrary code</title>
<synopsis>The GPGSM utility included in GnuPG contains a use-after-free
vulnerability that may allow an unauthenticated remote attacker to execute
arbitrary code.
<product type="ebuild">GnuPG</product>
<announced>October 22, 2011</announced>
<revised>October 22, 2011: 1</revised>
<package name="app-crypt/gnupg" auto="yes" arch="*">
<unaffected range="ge">2.0.16-r1</unaffected>
<unaffected range="lt">2.0</unaffected>
<vulnerable range="lt">2.0.16-r1</vulnerable>
<p>The GNU Privacy Guard, GnuPG, is a free replacement for the PGP suite of
cryptographic software. The GPGSM utility in GnuPG is responsible for
processing X.509 certificates, signatures and encryption as well as
S/MIME messages.
<p>The GPGSM utility in GnuPG contains a use-after-free vulnerability that
may be exploited when importing a crafted X.509 certificate explicitly or
during the signature verification process.
<impact type="normal">
<p>An unauthenticated remote attacker may execute arbitrary code with the
privileges of the user running GnuPG by enticing them to import a crafted
<p>There is no known workaround at this time.</p>
<p>All GnuPG 2.x users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=app-crypt/gnupg-2.0.16-r1"
<uri link="">CVE-2010-2547</uri>
<metadata timestamp="Fri, 07 Oct 2011 23:38:19 +0000" tag="requester">system</metadata>
<metadata timestamp="Sat, 22 Oct 2011 04:24:43 +0000" tag="submitter">