blob: 716cd2dba816d2ed444a9548ba91009edf6af6e8 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201206-18">
<title>GnuTLS: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities have been found in GnuTLS, allowing a
remote attacker to perform man-in-the-middle or Denial of Service attacks.
<product type="ebuild">GnuTLS</product>
<announced>June 23, 2012</announced>
<revised>June 23, 2012: 1</revised>
<package name="net-libs/gnutls" auto="yes" arch="*">
<unaffected range="ge">2.12.18</unaffected>
<vulnerable range="lt">2.12.18</vulnerable>
<p>GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0
<p>Multiple vulnerabilities have been found in GnuTLS:</p>
<li>An error in libgnutls does not properly sanitize "\0" characters from
certificate fields (CVE-2009-2730).
<li>An error in the TLS and SSL protocols mistreats renegotiation
handshakes (CVE-2009-3555).
<li>A boundary error in the "gnutls_session_get_data()" function in
gnutls_session.c could cause a buffer overflow (CVE-2011-4128).
<li>An error in the "_gnutls_ciphertext2compressed()" function in
gnutls_cipher.c could cause memory corruption (CVE-2012-1573).
<impact type="normal">
<p>A remote attacker could perform man-in-the-middle attacks to spoof
arbitrary SSL servers or cause a Denial of Service condition in
applications linked against GnuTLS.
<p>There is no known workaround at this time.</p>
<p>All GnuTLS users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=net-libs/gnutls-2.12.18"
<uri link="">CVE-2009-2730</uri>
<uri link="">CVE-2009-3555</uri>
<uri link="">CVE-2011-4128</uri>
<uri link="">CVE-2012-1573</uri>
<metadata timestamp="Tue, 17 Apr 2012 00:40:28 +0000" tag="requester">ackle</metadata>
<metadata timestamp="Sat, 23 Jun 2012 14:21:06 +0000" tag="submitter">ackle</metadata>