blob: 8147f0539cabf7dcb1b6817c597dbe035d0443f4 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201206-24">
<title>Apache Tomcat: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities were found in Apache Tomcat, the worst of
which allowing to read, modify and overwrite arbitrary files.
<product type="ebuild">apache tomcat</product>
<announced>June 24, 2012</announced>
<revised>March 20, 2016: 3</revised>
<access>local, remote</access>
<package name="www-servers/tomcat" auto="yes" arch="*">
<unaffected range="rge">6.0.35</unaffected>
<unaffected range="ge">7.0.23</unaffected>
<unaffected range="rge">6.0.44</unaffected>
<unaffected range="rge">6.0.45</unaffected>
<unaffected range="rge">6.0.46</unaffected>
<unaffected range="rge">6.0.47</unaffected>
<unaffected range="rge">6.0.48</unaffected>
<vulnerable range="lt">7.0.23</vulnerable>
<p>Apache Tomcat is a Servlet-3.0/JSP-2.2 Container.</p>
<p>Multiple vulnerabilities have been discovered in Apache Tomcat. Please
review the CVE identifiers referenced below for details.
<impact type="normal">
<p>The vulnerabilities allow an attacker to cause a Denial of Service, to
hijack a session, to bypass authentication, to inject webscript, to
enumerate valid usernames, to read, modify and overwrite arbitrary files,
to bypass intended access restrictions, to delete work-directory files,
to discover the server’s hostname or IP, to bypass read permissions for
files or HTTP headers, to read or write files outside of the intended
working directory, and to obtain sensitive information by reading a log
<p>There is no known workaround at this time.</p>
<p>All Apache Tomcat 6.0.x users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=www-servers/tomcat-6.0.35"
<p>All Apache Tomcat 7.0.x users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=www-servers/tomcat-7.0.23"
<uri link="">CVE-2008-5515</uri>
<uri link="">CVE-2009-0033</uri>
<uri link="">CVE-2009-0580</uri>
<uri link="">CVE-2009-0781</uri>
<uri link="">CVE-2009-0783</uri>
<uri link="">CVE-2009-2693</uri>
<uri link="">CVE-2009-2901</uri>
<uri link="">CVE-2009-2902</uri>
<uri link="">CVE-2010-1157</uri>
<uri link="">CVE-2010-2227</uri>
<uri link="">CVE-2010-3718</uri>
<uri link="">CVE-2010-4172</uri>
<uri link="">CVE-2010-4312</uri>
<uri link="">CVE-2011-0013</uri>
<uri link="">CVE-2011-0534</uri>
<uri link="">CVE-2011-1088</uri>
<uri link="">CVE-2011-1183</uri>
<uri link="">CVE-2011-1184</uri>
<uri link="">CVE-2011-1419</uri>
<uri link="">CVE-2011-1475</uri>
<uri link="">CVE-2011-1582</uri>
<uri link="">CVE-2011-2204</uri>
<uri link="">CVE-2011-2481</uri>
<uri link="">CVE-2011-2526</uri>
<uri link="">CVE-2011-2729</uri>
<uri link="">CVE-2011-3190</uri>
<uri link="">CVE-2011-3375</uri>
<uri link="">CVE-2011-4858</uri>
<uri link="">CVE-2011-5062</uri>
<uri link="">CVE-2011-5063</uri>
<uri link="">CVE-2011-5064</uri>
<uri link="">CVE-2012-0022</uri>
<metadata tag="requester" timestamp="Fri, 07 Oct 2011 23:38:00 +0000">craig</metadata>
<metadata tag="submitter" timestamp="Sun, 20 Mar 2016 14:15:43 +0000">