blob: 796bf1260d3f72146301fea1032a33d3ee829be0 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201206-33">
<title>Postfix: Multiple vulnerabilities </title>
<synopsis>A vulnerability has been found in Postfix, the worst of which
possibly allowing remote code execution.
</synopsis>
<product type="ebuild">Postfix</product>
<announced>June 25, 2012</announced>
<revised>June 25, 2012: 1</revised>
<bug>358085</bug>
<bug>366605</bug>
<access>remote</access>
<affected>
<package name="mail-mta/postfix" auto="yes" arch="*">
<unaffected range="ge">2.7.4</unaffected>
<vulnerable range="lt">2.7.4</vulnerable>
</package>
</affected>
<background>
<p>Postfix is Wietse Venema’s mailer that attempts to be fast, easy to
administer, and secure, as an alternative to the widely-used Sendmail
program.
</p>
</background>
<description>
<p>A vulnerability have been discovered in Postfix. Please review the CVE
identifier referenced below for details.
</p>
</description>
<impact type="high">
<p>An attacker could perform a man-in-the-middle attack and inject SMTP
commands during the plaintext to TLS session switch or might execute
arbitrary code.
</p>
</impact>
<workaround>
<p>There is no known workaround at this time.</p>
</workaround>
<resolution>
<p>All Postfix users should upgrade to the latest version:</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=mail-mta/postfix-2.7.4"
</code>
</resolution>
<references>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-0411">CVE-2011-0411</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1720">CVE-2011-1720</uri>
</references>
<metadata timestamp="Fri, 07 Oct 2011 23:37:03 +0000" tag="requester">craig</metadata>
<metadata timestamp="Mon, 25 Jun 2012 18:51:42 +0000" tag="submitter">craig</metadata>
</glsa>