blob: f655550199b36e5e5a926fed927a247e89e67669 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201209-14">
<title>file: Denial of Service</title>
<synopsis>A vulnerability in file could result in Denial of Service.</synopsis>
<product type="ebuild">file</product>
<announced>September 26, 2012</announced>
<revised>September 26, 2012: 1</revised>
<bug>427368</bug>
<access>remote</access>
<affected>
<package name="sys-apps/file" auto="yes" arch="*">
<unaffected range="ge">5.11</unaffected>
<vulnerable range="lt">5.11</vulnerable>
</package>
</affected>
<background>
<p>file is a utility that guesses a file format by scanning binary data for
patterns.
</p>
</background>
<description>
<p>Multiple out-of-bounds read errors and invalid pointer dereference
errors have been found in cdf.c.
</p>
</description>
<impact type="normal">
<p>A remote attacker could entice a user to open a specially crafted
Composite Document File (CDF) using file, possibly resulting in a Denial
of Service condition.
</p>
</impact>
<workaround>
<p>There is no known workaround at this time.</p>
</workaround>
<resolution>
<p>All file users should upgrade to the latest version:</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=sys-apps/file-5.11"
</code>
</resolution>
<references>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1571">CVE-2012-1571</uri>
</references>
<metadata tag="requester" timestamp="Sun, 22 Jul 2012 16:44:09 +0000">ackle</metadata>
<metadata tag="submitter" timestamp="Wed, 26 Sep 2012 11:11:29 +0000">ackle</metadata>
</glsa>