blob: 69dbcddcb25a67fba4cddb9dc4c9b91ca37c8387 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201310-06">
<title>Aircrack-ng: User-assisted execution of arbitrary code</title>
<synopsis>A buffer overflow vulnerability in Aircrack-ng could result in
execution of arbitrary code or Denial of Service.
</synopsis>
<product type="ebuild">aircrack-ng</product>
<announced>October 07, 2013</announced>
<revised>October 07, 2013: 1</revised>
<bug>311797</bug>
<access>remote</access>
<affected>
<package name="net-wireless/aircrack-ng" auto="yes" arch="*">
<unaffected range="ge">1.1-r2</unaffected>
<vulnerable range="lt">1.1-r2</vulnerable>
</package>
</affected>
<background>
<p>Aircrack-ng is an 802.11 WEP and WPA-PSK keys cracking program that can
recover keys once enough data packets have been captured.
</p>
</background>
<description>
<p>A buffer overflow vulnerability has been discovered in Aircrack-ng.</p>
</description>
<impact type="normal">
<p>A remote attacker could entice a user to open a specially crafted dump
file using Aircrack-ng, possibly resulting in execution of arbitrary code
with the privileges of the process or a Denial of Service condition.
</p>
</impact>
<workaround>
<p>There is no known workaround at this time.</p>
</workaround>
<resolution>
<p>All Aircrack-ng users should upgrade to the latest version:</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=net-wireless/aircrack-ng-1.1-r2"
</code>
</resolution>
<references>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-1159">CVE-2010-1159</uri>
</references>
<metadata tag="requester" timestamp="Sun, 23 Dec 2012 23:18:18 +0000">ackle</metadata>
<metadata tag="submitter" timestamp="Mon, 07 Oct 2013 08:46:58 +0000">ackle</metadata>
</glsa>