blob: bf229bd420fec63910e5a75f9251f4cef86cb3ff [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201401-26">
<title>Zabbix: Shell command injection</title>
<synopsis>A vulnerability in Zabbix could allow remote attackers to execute
arbitrary shell code.
</synopsis>
<product type="ebuild">zabbix</product>
<announced>January 23, 2014</announced>
<revised>June 02, 2014: 2</revised>
<bug>493250</bug>
<access>remote</access>
<affected>
<package name="net-analyzer/zabbix" auto="yes" arch="*">
<unaffected range="ge">2.0.9-r1</unaffected>
<vulnerable range="lt">2.0.9-r1</vulnerable>
</package>
</affected>
<background>
<p>Zabbix is software for monitoring applications, networks, and servers.</p>
</background>
<description>
<p>If a flexible user parameter is configured in Zabbix agent, including a
newline in the parameters will execute newline section as a separate
command even if UnsafeUserParameters are disabled.
</p>
</description>
<impact type="high">
<p>A remote attacker could possibly execute arbitrary shell code with the
privileges of the process.
</p>
</impact>
<workaround>
<p>There is no known workaround at this time.</p>
</workaround>
<resolution>
<p>All Zabbix 2.2 users should upgrade to the latest version:</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=net-analyzer/zabbix-2.2.0-r4"
</code>
<p>All Zabbix 2.0 users should upgrade to the latest version:</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=net-analyzer/zabbix-2.0.9-r1"
</code>
</resolution>
<references>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-6824">CVE-2013-6824</uri>
</references>
<metadata tag="requester" timestamp="Tue, 17 Dec 2013 19:46:48 +0000">Zlogene</metadata>
<metadata tag="submitter" timestamp="Mon, 02 Jun 2014 13:59:58 +0000">
pinkbyte
</metadata>
</glsa>