blob: 86e88be413c3b52c310b01fa15c5837489eb9764 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201405-24">
<title>Apache Portable Runtime, APR Utility Library: Denial of Service</title>
<synopsis>Memory consumption errors in Apache Portable Runtime and APR
Utility Library could result in Denial of Service.
<product type="ebuild">apr apr-util</product>
<announced>May 18, 2014</announced>
<revised>May 18, 2014: 1</revised>
<package name="dev-libs/apr" auto="yes" arch="*">
<unaffected range="ge">1.4.8-r1</unaffected>
<vulnerable range="lt">1.4.8-r1</vulnerable>
<package name="dev-libs/apr-util" auto="yes" arch="*">
<unaffected range="ge">1.3.10</unaffected>
<vulnerable range="lt">1.3.10</vulnerable>
<p>The Apache Portable Runtime (aka APR) provides a set of APIs for
creating platform-independent applications. The Apache Portable Runtime
Utility Library (aka APR-Util) provides an interface to functionality
such as XML parsing, string matching and database connections.
<p>Multiple vulnerabilities have been discovered in Apache Portable Runtime
and APR Utility Library. Please review the CVE identifiers referenced
below for details.
<impact type="low">
<p>A remote attacker could cause a Denial of Service condition.</p>
<p>There is no known workaround at this time.</p>
<p>All Apache Portable Runtime users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-libs/apr-1.4.8-r1"
<p>All users of the APR Utility Library should upgrade to the latest
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-libs/apr-util-1.3.10"
<p>Packages which depend on these libraries may need to be recompiled.
Tools such as revdep-rebuild may assist in identifying some of these
<uri link="">CVE-2010-1623</uri>
<uri link="">CVE-2011-0419</uri>
<uri link="">CVE-2011-1928</uri>
<uri link="">CVE-2012-0840</uri>
<metadata tag="requester" timestamp="Fri, 07 Oct 2011 23:37:24 +0000">
<metadata tag="submitter" timestamp="Sun, 18 May 2014 17:30:44 +0000">ackle</metadata>