blob: 12036147e954ba3fd144fae175d07a91c006afbe [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201406-01">
<title>D-Bus, GLib: Privilege escalation</title>
<synopsis>A vulnerability has been found in D-Bus which allows local
attackers to gain escalated privileges.
<product type="ebuild">dbus</product>
<announced>June 01, 2014</announced>
<revised>June 01, 2014: 1</revised>
<package name="sys-apps/dbus" auto="yes" arch="*">
<unaffected range="ge">1.6.8</unaffected>
<vulnerable range="lt">1.6.8</vulnerable>
<package name="dev-libs/glib" auto="yes" arch="*">
<unaffected range="ge">2.32.4-r1</unaffected>
<vulnerable range="lt">2.32.4-r1</vulnerable>
<p>D-Bus is a daemon providing a framework for applications to communicate
with one another. GLib is a library providing a number of GNOME’s core
objects and functions.
<p>When libdbus is used in a setuid program, a user can gain escalated
privileges by leveraging the DBUS_SYSTEM_BUS_ADDRESS variable. GLib can
be used in a setuid context with D-Bus, and so can trigger this
vulnerability. Please review the CVE identifier below for more details.
<impact type="high">
<p>A local attacker could gain escalated privileges and execute arbitrary
<p>There is no known workaround at this time.</p>
<p>All D-Bus users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=sys-apps/dbus-1.6.8"
<p>All GLib users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-libs/glib-2.32.4-r1"
<uri link="">CVE-2012-3524</uri>
<metadata tag="requester" timestamp="Sun, 14 Oct 2012 18:04:56 +0000">ackle</metadata>
<metadata tag="submitter" timestamp="Sun, 01 Jun 2014 14:05:31 +0000">