blob: 4bf458c8ea6575f1b9c54f1a095be734dc57cf8d [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201406-09">
<title>GnuTLS: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities have been discovered in GnuTLS, the worst
of which could lead to arbitrary code execution.
</synopsis>
<product type="ebuild">gnutls</product>
<announced>June 13, 2014</announced>
<revised>June 13, 2014: 1</revised>
<bug>501282</bug>
<bug>503394</bug>
<bug>511840</bug>
<access>remote</access>
<affected>
<package name="net-libs/gnutls" auto="yes" arch="*">
<unaffected range="ge">2.12.23-r6</unaffected>
<vulnerable range="lt">2.12.23-r6</vulnerable>
</package>
</affected>
<background>
<p>GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0
protocols.
</p>
</background>
<description>
<p>Multiple vulnerabilities have been discovered in GnuTLS. Please review
the CVE identifiers referenced below for details.
</p>
</description>
<impact type="normal">
<p>A remote attacker could utilize multiple vectors to spoof arbitrary SSL
servers via a crafted certificate, execute arbitrary code or cause a
Denial of Service condition.
</p>
</impact>
<workaround>
<p>There is no known workaround at this time.</p>
</workaround>
<resolution>
<p>All GnuTLS users should upgrade to the latest version:</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=net-libs/gnutls-2.12.23-r6"
</code>
</resolution>
<references>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0092">CVE-2014-0092</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-1959">CVE-2014-1959</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3465">CVE-2014-3465</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3466">CVE-2014-3466</uri>
</references>
<metadata tag="requester" timestamp="Mon, 24 Mar 2014 21:52:06 +0000">
BlueKnight
</metadata>
<metadata tag="submitter" timestamp="Fri, 13 Jun 2014 19:35:08 +0000">Zlogene</metadata>
</glsa>