blob: a5f61126bd4bdf40d5833b537cb1439934918e10 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201406-35">
<title>Openfire: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities have been found in Openfire, the worst of
which could lead to a Denial of Service condition.
</synopsis>
<product type="ebuild">openfire</product>
<announced>June 30, 2014</announced>
<revised>June 30, 2014: 1</revised>
<bug>266129</bug>
<bug>507242</bug>
<access>remote</access>
<affected>
<package name="net-im/openfire" auto="yes" arch="*">
<unaffected range="ge">3.9.2-r1</unaffected>
<vulnerable range="lt">3.9.2-r1</vulnerable>
</package>
</affected>
<background>
<p>Openfire is a real time collaboration (RTC) server.</p>
</background>
<description>
<p>Multiple vulnerabilities have been discovered in Openfire. Please review
the CVE identifiers referenced below for details.
</p>
</description>
<impact type="normal">
<p>A remote attacker could possibly cause a Denial of Service condition or
bypass security restrictions.
</p>
</impact>
<workaround>
<p>There is no known workaround at this time.</p>
</workaround>
<resolution>
<p>All Openfire users should upgrade to the latest version:</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=net-im/openfire-3.9.2-r1"
</code>
</resolution>
<references>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1595">CVE-2009-1595</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-1596">CVE-2009-1596</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2741">CVE-2014-2741</uri>
</references>
<metadata tag="requester" timestamp="Tue, 10 Jun 2014 01:12:58 +0000">
BlueKnight
</metadata>
<metadata tag="submitter" timestamp="Mon, 30 Jun 2014 17:52:11 +0000">Zlogene</metadata>
</glsa>