blob: 882adbbe88f40f4f58f96aa4bb98ea7dccc8d05d [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201408-11">
<title>PHP: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities have been discovered in PHP, the worst of
which could lead to remote execution of arbitrary code.
<product type="ebuild">php</product>
<announced>August 29, 2014</announced>
<revised>August 22, 2015: 4</revised>
<package name="dev-lang/php" auto="yes" arch="*">
<unaffected range="ge">5.5.16</unaffected>
<unaffected range="rge">5.4.32</unaffected>
<unaffected range="rge">5.3.29</unaffected>
<unaffected range="rge">5.4.34</unaffected>
<unaffected range="rge">5.4.35</unaffected>
<unaffected range="rge">5.4.36</unaffected>
<unaffected range="rge">5.4.37</unaffected>
<unaffected range="rge">5.4.38</unaffected>
<unaffected range="rge">5.4.39</unaffected>
<unaffected range="rge">5.4.40</unaffected>
<unaffected range="rge">5.4.41</unaffected>
<unaffected range="rge">5.4.42</unaffected>
<unaffected range="rge">5.4.43</unaffected>
<unaffected range="rge">5.4.44</unaffected>
<unaffected range="rge">5.4.45</unaffected>
<unaffected range="rge">5.4.46</unaffected>
<vulnerable range="lt">5.5.16</vulnerable>
<p>PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.
<p>Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers referenced below for details.
<impact type="high">
<p>A context-dependent attacker can cause arbitrary code execution, create
a Denial of Service condition, read or write arbitrary files, impersonate
other servers, hijack a web session, or have other unspecified impact.
Additionally, a local attacker could gain escalated privileges.
<p>There is no known workaround at this time.</p>
<p>All PHP 5.5 users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-lang/php-5.5.16"
<p>All PHP 5.4 users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-lang/php-5.4.32"
<p>All PHP 5.3 users should upgrade to the latest version. This release
marks the end of life of the PHP 5.3 series. Future releases of this
series are not planned. All PHP 5.3 users are encouraged to upgrade to
the current stable version of PHP 5.5 or previous stable version of PHP
5.4, which are supported till at least 2016 and 2015 respectively.
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-lang/php-5.3.29"
<uri link="">CVE-2011-4718</uri>
<uri link="">CVE-2013-1635</uri>
<uri link="">CVE-2013-1643</uri>
<uri link="">CVE-2013-1824</uri>
<uri link="">CVE-2013-2110</uri>
<uri link="">CVE-2013-3735</uri>
<uri link="">CVE-2013-4113</uri>
<uri link="">CVE-2013-4248</uri>
<uri link="">CVE-2013-4635</uri>
<uri link="">CVE-2013-4636</uri>
<uri link="">CVE-2013-6420</uri>
<uri link="">CVE-2013-6712</uri>
<uri link="">CVE-2013-7226</uri>
<uri link="">CVE-2013-7327</uri>
<uri link="">CVE-2013-7345</uri>
<uri link="">CVE-2014-0185</uri>
<uri link="">CVE-2014-0237</uri>
<uri link="">CVE-2014-0238</uri>
<uri link="">CVE-2014-1943</uri>
<uri link="">CVE-2014-2270</uri>
<uri link="">CVE-2014-2497</uri>
<uri link="">CVE-2014-3597</uri>
<uri link="">CVE-2014-3981</uri>
<uri link="">CVE-2014-4049</uri>
<uri link="">CVE-2014-4670</uri>
<uri link="">CVE-2014-5120</uri>
<metadata tag="requester" timestamp="Fri, 23 Aug 2013 14:19:36 +0000">
<metadata tag="submitter" timestamp="Sat, 22 Aug 2015 22:25:57 +0000">