blob: 5150a706505eabf70cfd5012bbae402de42eefdc [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201411-04">
<title>PHP: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities have been discovered in PHP, the worst of
which could lead to remote execution of arbitrary code.
<product type="ebuild">php</product>
<announced>November 09, 2014</announced>
<revised>August 22, 2015: 3</revised>
<package name="dev-lang/php" auto="yes" arch="*">
<unaffected range="ge">5.5.18</unaffected>
<unaffected range="rge">5.4.34</unaffected>
<unaffected range="rge">5.3.29</unaffected>
<unaffected range="rge">5.4.36</unaffected>
<unaffected range="rge">5.4.37</unaffected>
<unaffected range="rge">5.4.38</unaffected>
<unaffected range="rge">5.4.39</unaffected>
<unaffected range="rge">5.4.35</unaffected>
<unaffected range="rge">5.4.40</unaffected>
<unaffected range="rge">5.4.41</unaffected>
<unaffected range="rge">5.4.42</unaffected>
<unaffected range="rge">5.4.43</unaffected>
<unaffected range="rge">5.4.44</unaffected>
<unaffected range="rge">5.4.45</unaffected>
<unaffected range="rge">5.4.46</unaffected>
<vulnerable range="lt">5.5.18</vulnerable>
<p>PHP is a widely-used general-purpose scripting language that is
especially suited for Web development and can be embedded into HTML.
<p>Multiple vulnerabilities have been discovered in PHP. Please review the
CVE identifiers referenced below for details.
<impact type="normal">
<p>A context-dependent attacker can possibly execute arbitrary code or
create a Denial of Service condition.
<p>There is no known workaround at this time.</p>
<p>All PHP 5.5 users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-lang/php-5.5.18"
<p>All PHP 5.4 users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-lang/php-5.4.34"
<p>All PHP 5.3 users should upgrade to the latest version. This release
marks the end of life of the PHP 5.3 series. Future releases of this
series are not planned. All PHP 5.3 users are encouraged to upgrade to
the current stable version of PHP 5.5 or previous stable version of PHP
5.4, which are supported till at least 2016 and 2015 respectively.
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-lang/php-5.3.29"
<uri link="">CVE-2014-3668</uri>
<uri link="">CVE-2014-3669</uri>
<uri link="">CVE-2014-3670</uri>
<metadata tag="requester" timestamp="Mon, 03 Nov 2014 23:38:25 +0000">ackle</metadata>
<metadata tag="submitter" timestamp="Sat, 22 Aug 2015 22:31:28 +0000">ackle</metadata>