blob: b895503a0089c949a38879b8ff307faff2e9946b [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201412-27">
<title>Ruby: Denial of Service</title>
<synopsis>Multiple vulnerabilities have been found in Ruby, allowing
context-dependent attackers to cause a Denial of Service condition.
<product type="ebuild">Ruby</product>
<announced>December 13, 2014</announced>
<revised>December 13, 2014: 1</revised>
<access>local, remote</access>
<package name="dev-lang/ruby" auto="yes" arch="*">
<unaffected range="rge">1.9.3_p551</unaffected>
<unaffected range="ge">2.0.0_p598</unaffected>
<vulnerable range="lt">2.0.0_p598</vulnerable>
<p>Ruby is an object-oriented scripting language.</p>
<p>Multiple vulnerabilities have been discovered in Ruby. Please review the
CVE identifiers referenced below for details.
<impact type="normal">
<p>A context-dependent attacker could possibly execute arbitrary code with
the privileges of the process, cause a Denial of Service condition, or
bypass security restrictions.
<p>There is no known workaround at this time.</p>
<p>All Ruby 1.9 users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-lang/ruby-1.9.3_p551"
<p>All Ruby 2.0 users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-lang/ruby-2.0.0_p598"
<uri link="">CVE-2011-0188</uri>
<uri link="">CVE-2011-1004</uri>
<uri link="">CVE-2011-1005</uri>
<uri link="">CVE-2011-4815</uri>
<uri link="">CVE-2012-4481</uri>
<uri link="">CVE-2012-5371</uri>
<uri link="">CVE-2013-0269</uri>
<uri link="">CVE-2013-1821</uri>
<uri link="">CVE-2013-4164</uri>
<uri link="">CVE-2014-8080</uri>
<uri link="">CVE-2014-8090</uri>
<metadata tag="requester" timestamp="Fri, 07 Oct 2011 23:37:04 +0000">
<metadata tag="submitter" timestamp="Sat, 13 Dec 2014 18:56:30 +0000">craig</metadata>