blob: 7154eca8529f075a409e514643b7726d09b59d01 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201412-47">
<title>TORQUE Resource Manager: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities have been found in TORQUE Resource
Manager, possibly resulting in escalation of privileges or remote code
execution.
</synopsis>
<product type="ebuild">torque</product>
<announced>December 26, 2014</announced>
<revised>December 26, 2014: 1</revised>
<bug>372959</bug>
<bug>378805</bug>
<bug>390167</bug>
<bug>484320</bug>
<bug>491270</bug>
<bug>510726</bug>
<access>local, remote</access>
<affected>
<package name="sys-cluster/torque" auto="yes" arch="*">
<unaffected range="ge">4.1.7</unaffected>
<unaffected range="rge">2.5.13</unaffected>
<vulnerable range="lt">4.1.7</vulnerable>
</package>
</affected>
<background>
<p>TORQUE is a resource manager and queuing system based on OpenPBS.</p>
</background>
<description>
<p>Multiple vulnerabilities have been discovered in TORQUE Resource
Manager. Please review the CVE identifiers referenced below for details.
</p>
</description>
<impact type="high">
<p>A context-dependent attacker may be able to gain escalated privileges,
execute arbitrary code, or bypass security restrictions.
</p>
</impact>
<workaround>
<p>There is no known workaround at this time.</p>
</workaround>
<resolution>
<p>All TORQUE Resource Manager 4.x users should upgrade to the latest
version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=sys-cluster/torque-4.1.7"
</code>
<p>All TORQUE Resource Manager 2.x users should upgrade to the latest
version:
</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=sys-cluster/torque-2.5.13"
</code>
<p>NOTE: One or more of the issues described in this advisory have been
fixed in previous updates. They are included in this advisory for the
sake of completeness. It is likely that your system is already no longer
affected by them.
</p>
</resolution>
<references>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2193">CVE-2011-2193</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-2907">CVE-2011-2907</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4925">CVE-2011-4925</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4319">CVE-2013-4319</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-4495">CVE-2013-4495</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0749">CVE-2014-0749</uri>
</references>
<metadata tag="requester" timestamp="Fri, 07 Oct 2011 23:38:08 +0000">
underling
</metadata>
<metadata tag="submitter" timestamp="Fri, 26 Dec 2014 19:24:57 +0000">ackle</metadata>
</glsa>