blob: 676e30f5ec22bb7595a117d05c57fa088249f2e1 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201503-11">
<title>OpenSSL: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities have been found in OpenSSL that can result
in either Denial of Service or information disclosure.
<product type="ebuild">openssl</product>
<announced>March 19, 2015</announced>
<revised>June 06, 2015: 2</revised>
<package name="dev-libs/openssl" auto="yes" arch="*">
<unaffected range="ge">1.0.1l-r1</unaffected>
<unaffected range="rge">0.9.8z_p5</unaffected>
<unaffected range="rge">0.9.8z_p6</unaffected>
<unaffected range="rge">0.9.8z_p7</unaffected>
<unaffected range="rge">0.9.8z_p8</unaffected>
<unaffected range="rge">0.9.8z_p9</unaffected>
<unaffected range="rge">0.9.8z_p10</unaffected>
<unaffected range="rge">0.9.8z_p11</unaffected>
<unaffected range="rge">0.9.8z_p12</unaffected>
<unaffected range="rge">0.9.8z_p13</unaffected>
<unaffected range="rge">0.9.8z_p14</unaffected>
<unaffected range="rge">0.9.8z_p15</unaffected>
<vulnerable range="lt">1.0.1l-r1</vulnerable>
<p>OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.
<p>Multiple vulnerabilities have been found in OpenSSL. Please review the
CVE identifiers and the upstream advisory referenced below for details:
<li>RSA silently downgrades to EXPORT_RSA [Client] (Reclassified)
<li>Segmentation fault in ASN1_TYPE_cmp (CVE-2015-0286)</li>
<li>ASN.1 structure reuse memory corruption (CVE-2015-0287)</li>
<li>X509_to_X509_REQ NULL pointer deref (CVE-2015-0288)</li>
<li>PKCS7 NULL pointer dereferences (CVE-2015-0289)</li>
<li>Base64 decode (CVE-2015-0292)</li>
<li>DoS via reachable assert in SSLv2 servers (CVE-2015-0293)</li>
<li>Use After Free following d2i_ECPrivatekey error (CVE-2015-0209)</li>
<p>The following issues affect OpenSSL 1.0.2 only which is not part of the
supported Gentoo stable tree:
<li>OpenSSL 1.0.2 ClientHello sigalgs DoS (CVE-2015-0291)</li>
<li>Multiblock corrupted pointer (CVE-2015-0290)</li>
<li>Segmentation fault in DTLSv1_listen (CVE-2015-0207)</li>
<li>Segmentation fault for invalid PSS parameters (CVE-2015-0208)</li>
<li>Empty CKE with client auth and DHE (CVE-2015-1787)</li>
<li>Handshake with unseeded PRNG (CVE-2015-0285)</li>
<impact type="normal">
<p>A remote attacker can utilize multiple vectors to cause Denial of
Service or Information Disclosure.
<p>There is no known workaround at this time.</p>
<p>All OpenSSL 1.0.1 users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-libs/openssl-1.0.1l-r1"
<p>All OpenSSL 0.9.8 users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-libs/openssl-0.9.8z_p5-r1"
<p>Packages which depend on the OpenSSL library need to be restarted for
the upgrade to take effect. Some packages may need to be recompiled.
Tools such as revdep-rebuild may assist in identifying some of these
<uri link="">CVE-2015-0204</uri>
<uri link="">CVE-2015-0207</uri>
<uri link="">CVE-2015-0208</uri>
<uri link="">CVE-2015-0209</uri>
<uri link="">CVE-2015-0285</uri>
<uri link="">CVE-2015-0287</uri>
<uri link="">CVE-2015-0288</uri>
<uri link="">CVE-2015-0289</uri>
<uri link="">CVE-2015-0290</uri>
<uri link="">CVE-2015-0291</uri>
<uri link="">CVE-2015-0292</uri>
<uri link="">CVE-2015-0293</uri>
<uri link="">CVE-2015-1787</uri>
<uri link="">OpenSSL Security
Advisory [19 Mar 2015]
<metadata tag="requester" timestamp="Thu, 19 Mar 2015 09:52:36 +0000">a3li</metadata>
<metadata tag="submitter" timestamp="Sat, 06 Jun 2015 23:16:23 +0000">K_F</metadata>