blob: 538c65d03ca5cc78a4c0e1c08487055ed293016a [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201504-05">
<title>MySQL and MariaDB: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities have been found in MySQL and MariaDB, the
worst of which can allow remote attackers to cause a Denial of Service
<product type="ebuild">mysql mariadb</product>
<announced>April 11, 2015</announced>
<revised>April 11, 2015: 1</revised>
<package name="dev-db/mysql" auto="yes" arch="*">
<unaffected range="ge">5.6.22</unaffected>
<vulnerable range="lt">5.6.22</vulnerable>
<package name="dev-db/mariadb" auto="yes" arch="*">
<unaffected range="ge">10.0.16</unaffected>
<unaffected range="rge">5.5.49</unaffected>
<vulnerable range="lt">10.0.16</vulnerable>
<p>MySQL is a popular multi-threaded, multi-user SQL server. MariaDB is an
enhanced, drop-in replacement for MySQL.
<p>Multiple vulnerabilities have been discovered in MySQL and MariaDB.
Please review the CVE identifiers referenced below for details.
<impact type="normal">
<p>A remote attacker could exploit vulnerabilities to possibly cause a
Denial of Service condition.
<p>There is no known workaround at this time.</p>
<p>All MySQL users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-db/mysql-5.6.22"
<p>All MariaDB users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-db/mariadb-10.0.16"
<uri link="">CVE-2014-6568</uri>
<uri link="">CVE-2015-0374</uri>
<uri link="">CVE-2015-0381</uri>
<uri link="">CVE-2015-0382</uri>
<uri link="">CVE-2015-0385</uri>
<uri link="">CVE-2015-0391</uri>
<uri link="">CVE-2015-0409</uri>
<uri link="">CVE-2015-0411</uri>
<uri link="">CVE-2015-0432</uri>
<metadata tag="requester" timestamp="Mon, 16 Feb 2015 14:04:19 +0000">
<metadata tag="submitter" timestamp="Sat, 11 Apr 2015 20:11:58 +0000">