blob: 425328a8b84b4921c09eb1ac7be0fbc308f301ab [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<glsa id="201512-07">
<title>GStreamer: User-assisted execution of arbitrary code</title>
<synopsis>A buffer overflow in GStreamer could allow remote attackers to
execute arbitrary code or cause Denial of Service.
<product type="ebuild">gstreamer</product>
<announced>December 30, 2015</announced>
<revised>February 09, 2016: 3</revised>
<package name="media-libs/gstreamer" auto="yes" arch="*">
<unaffected range="ge">1.4.5</unaffected>
<unaffected range="rge">0.10.36-r2</unaffected>
<vulnerable range="lt">1.4.5</vulnerable>
<package name="media-libs/gst-plugins-bad" auto="yes" arch="*">
<unaffected range="rge">0.10.23-r3</unaffected>
<vulnerable range="lt">0.10.23-r3</vulnerable>
<p>GStreamer is an open source multimedia framework.</p>
<p>A buffer overflow vulnerability has been found in the parsing of H.264
formatted video.
<impact type="normal">
<p>A remote attacker could entice a user to open a specially crafted H.264
formatted video using an application linked against GStreamer, possibly
resulting in execution of arbitrary code with the privileges of the
process or a Denial of Service condition.
<p>There is no known workaround at this time.</p>
<p>All GStreamer users should upgrade to the latest version:</p>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=media-libs/gstreamer-1.4.5"
<uri link="">CVE-2015-0797</uri>
<metadata tag="requester" timestamp="Sun, 22 Nov 2015 14:47:48 +0000">
<metadata tag="submitter" timestamp="Tue, 09 Feb 2016 20:37:29 +0000">ackle</metadata>