blob: 69223e829d09f521b3b7fe2ab9e0e66d1fe6a223 [file] [log] [blame]
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE glsa SYSTEM "http://www.gentoo.org/dtd/glsa.dtd">
<glsa id="201601-05">
<title>OpenSSL: Multiple vulnerabilities</title>
<synopsis>Multiple vulnerabilities have been found in OpenSSL, allowing
remote attackers to disclose sensitive information and complete weak
handshakes.
</synopsis>
<product type="ebuild">openssl</product>
<announced>January 29, 2016</announced>
<revised>February 26, 2016: 3</revised>
<bug>572854</bug>
<access>remote</access>
<affected>
<package name="dev-libs/openssl" auto="yes" arch="*">
<unaffected range="ge">1.0.2f</unaffected>
<unaffected range="rge">1.0.1r</unaffected>
<unaffected range="rge">1.0.1s</unaffected>
<unaffected range="rge">1.0.1t</unaffected>
<unaffected range="rge">0.9.8z_p8</unaffected>
<unaffected range="rge">0.9.8z_p9</unaffected>
<unaffected range="rge">0.9.8z_p10</unaffected>
<unaffected range="rge">0.9.8z_p11</unaffected>
<unaffected range="rge">0.9.8z_p12</unaffected>
<unaffected range="rge">0.9.8z_p13</unaffected>
<unaffected range="rge">0.9.8z_p14</unaffected>
<unaffected range="rge">0.9.8z_p15</unaffected>
<vulnerable range="lt">1.0.2f</vulnerable>
</package>
</affected>
<background>
<p>OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.
</p>
</background>
<description>
<p>Multiple vulnerabilities have been discovered in OpenSSL. Please review
the upstream advisory and CVE identifiers referenced below for details.
Note that the list includes CVE identifiers for an older OpenSSL Security
Advisory (3 Dec 2015) for which we have not issued a GLSA before.
</p>
</description>
<impact type="normal">
<p>A remote attacker could disclose a server’s private DH exponent, or
complete SSLv2 handshakes using ciphers that have been disabled on the
server.
</p>
</impact>
<workaround>
<p>There is no known workaround at this time.</p>
</workaround>
<resolution>
<p>All OpenSSL users should upgrade to the latest version:</p>
<code>
# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=dev-libs/openssl-1.0.2f"
</code>
</resolution>
<references>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-1794">CVE-2015-1794</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3193">CVE-2015-3193</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3194">CVE-2015-3194</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3195">CVE-2015-3195</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3196">CVE-2015-3196</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-3197">CVE-2015-3197</uri>
<uri link="http://nvd.nist.gov/nvd.cfm?cvename=CVE-2016-0701">CVE-2016-0701</uri>
<uri link="http://openssl.org/news/secadv/20160128.txt">OpenSSL Security
Advisory [28th Jan 2016]
</uri>
</references>
<metadata tag="requester" timestamp="Fri, 29 Jan 2016 23:06:05 +0000">
keytoaster
</metadata>
<metadata tag="submitter" timestamp="Fri, 26 Feb 2016 15:29:47 +0000">
keytoaster
</metadata>
</glsa>