blob: 0438190336af226e6d30464ab0cbb18c2656fbc2 [file] [log] [blame]
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit eutils
DESCRIPTION="Advanced Internet Whois client capable of recursive queries"
HOMEPAGE="https://www.gnu.org/software/jwhois/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
IUSE="nls"
DEPEND=""
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-whois-de.patch #159776
}
src_compile() {
econf \
--localstatedir=/var/cache \
--without-cache \
$(use_enable nls) \
|| die "econf failed"
emake || die
}
src_install() {
make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog NEWS README TODO
}