blob: 65d28f5b91c526eb3d33efa7f02d2ebec3314ad2 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
DESCRIPTION="CLI tool that pipes video streams from services like twitch.tv into a video player"
HOMEPAGE="https://github.com/chrippa/livestreamer"
SRC_URI="https://github.com/chrippa/livestreamer/archive/v${PV}.tar.gz -> ${P}.tar.gz"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
KEYWORDS="~amd64 ~mips ~x86"
LICENSE="BSD-2 MIT-with-advertising"
SLOT="0"
IUSE="doc test"
RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
>=dev-python/requests-1.0[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
virtual/python-singledispatch[${PYTHON_USEDEP}]
>media-video/rtmpdump-2.4"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND} )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
esetup.py test
}
python_install_all() {
use doc && local HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}