blob: 3f2e8106fe45a6d1d051412de351b7240f2a93da [file] [log] [blame]
# ChangeLog for x11-misc/qterm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/x11-misc/qterm/ChangeLog,v 1.50 2015/04/05 16:08:13 kensington Exp $
*qterm-0.5.12-r1 (05 Apr 2015)
05 Apr 2015; Michael Palimaka <kensington@gentoo.org> +qterm-0.5.12-r1.ebuild:
Migrate to EAPI 5.
12 May 2013; Naohiro Aota <naota@gentoo.org> qterm-0.5.12.ebuild:
Update HOMEPAGE. #469372
12 May 2013; Naohiro Aota <naota@gentoo.org> -qterm-0.5.11.ebuild:
Drop old version
02 Mar 2013; Markos Chandras <hwoarang@gentoo.org> qterm-0.5.11.ebuild,
qterm-0.5.12.ebuild:
Move Qt dependencies to the new category
21 Aug 2012; Naohiro Aota <naota@gentoo.org>
+files/qterm-0.5.12-glibc216.patch, qterm-0.5.12.ebuild:
Add patch from upstrem to fix build failure with gcc 4.7. #427490
19 Jul 2012; Michael Palimaka <kensington@gentoo.org> qterm-0.5.12.ebuild:
Add missing slot dependencies on Qt.
25 Mar 2012; Brent Baude <ranger@gentoo.org> qterm-0.5.12.ebuild:
Marking qterm-0.5.12 ppc for bug 400531
24 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> qterm-0.5.12.ebuild:
x86 stable wrt bug #400531
20 Mar 2012; Agostino Sarubbo <ago@gentoo.org> qterm-0.5.12.ebuild:
Stable for amd64, wrt bug #400531
14 Mar 2012; Naohiro Aota <naota@gentoo.org> qterm-0.5.11.ebuild:
Add workaround patch to drop cmake 2.6.x compatible statement. Bug #407997
14 Mar 2012; Naohiro Aota <naota@gentoo.org> qterm-0.5.12.ebuild:
Add missing dependency: kde-base/kdelibs and x11-libs/qt-assistant. Bug
#405577
*qterm-0.5.12 (18 Aug 2011)
18 Aug 2011; Naohiro Aota <naota@gentoo.org> +qterm-0.5.12.ebuild,
+files/qterm-0.5.12-qt4.patch:
Version bump; Add patch to drop cmake 2.6.x compatible statement
29 Jan 2011; Tomáš Chvátal <scarabeus@gentoo.org> -qterm-0.5.2-r2.ebuild,
-files/qterm-0.5.2-abs.patch, -files/qterm-0.5.2-as-needed.patch,
-files/qterm-0.5.2-include.patch, -qterm-0.5.7.ebuild,
-qterm-0.5.7-r1.ebuild, -files/qterm-0.5.7-gentoo.patch, -qterm-0.5.8.ebuild,
qterm-0.5.11.ebuild:
Stabilise latest. Drop old. Cleanup ebuild a bit.
*qterm-0.5.11 (08 Oct 2010)
08 Oct 2010; Alex Alexander <wired@gentoo.org> +qterm-0.5.11.ebuild,
+files/qterm-0.5.11-gentoo.patch:
version bump, fixes bug #338833
*qterm-0.5.8 (15 Dec 2009)
15 Dec 2009; MATSUU Takuto <matsuu@gentoo.org> +qterm-0.5.8.ebuild:
Version bumped. Added qt3support, bug #296507.
*qterm-0.5.7-r1 (02 Oct 2009)
02 Oct 2009; MATSUU Takuto <matsuu@gentoo.org> +qterm-0.5.7-r1.ebuild,
+files/qterm-0.5.7-gentoo.patch:
Fixed desktop file, bug #287212.
*qterm-0.5.7 (22 Sep 2009)
22 Sep 2009; Patrick Lauer <patrick@gentoo.org> +qterm-0.5.7.ebuild:
Bump to 0.5.7
22 Sep 2009; Patrick Lauer <patrick@gentoo.org> qterm-0.5.2-r2.ebuild,
+files/qterm-0.5.2-include.patch:
Fixing compile failure, thanks to Ian Whyman. Closes #276185
20 Mar 2009; Markos Chandras <hwoarang@gentoo.org> -qterm-0.5.2.ebuild,
-qterm-0.5.2-r1.ebuild:
Dropping old packages due to qt-4.3 removal
21 Jan 2009; Markus Meier <maekke@gentoo.org> qterm-0.5.2-r2.ebuild:
x86 stable, bug #248038
*qterm-0.5.2-r2 (19 Jan 2009)
19 Jan 2009; Ben de Groot <yngwin@gentoo.org>
+files/qterm-0.5.2-as-needed.patch, +qterm-0.5.2-r2.ebuild:
Fix Qt dep for bug 248038 and in the process fix bug 225117 by applying
suggested as-needed patch.
*qterm-0.5.2-r1 (03 Nov 2008)
03 Nov 2008; MATSUU Takuto <matsuu@gentoo.org>
+files/qterm-0.5.2-abs.patch, -qterm-0.4.0.ebuild, -qterm-0.4.0-r1.ebuild,
+qterm-0.5.2-r1.ebuild:
Fixed gcc-4.3 issue, bug #228225. Removed old versions.
28 Jul 2008; Carsten Lohrke <carlo@gentoo.org> qterm-0.4.0-r1.ebuild,
qterm-0.5.2.ebuild:
QA: Get rid of deprecated qt_min_version(). Please fix your ebuilds to
support split Qt 4.4 dependencies, cf. bug 217161 comment 11.
21 Jun 2008; nixnut <nixnut@gentoo.org> qterm-0.5.2.ebuild:
Stable on ppc wrt bug 216466
21 Jun 2008; Christian Faulhammer <opfer@gentoo.org> qterm-0.5.2.ebuild:
stable x86, bug 216466
*qterm-0.5.2 (14 May 2008)
14 May 2008; MATSUU Takuto <matsuu@gentoo.org> +qterm-0.5.2.ebuild:
Version bumped, bug #216983.
22 Jan 2008; MATSUU Takuto <matsuu@gentoo.org> qterm-0.4.0-r1.ebuild:
Fixed typo, bug #206887.
19 Jan 2008; MATSUU Takuto <matsuu@gentoo.org> qterm-0.4.0-r1.ebuild:
Fixed dependency, bug #204959.
10 Jan 2008; MATSUU Takuto <matsuu@gentoo.org> qterm-0.4.0-r1.ebuild:
Added pkg_postinst. bug #176533.
*qterm-0.4.0-r1 (24 Dec 2007)
24 Dec 2007; MATSUU Takuto <matsuu@gentoo.org> +qterm-0.4.0-r1.ebuild:
Renamed from /usr/bin/qterm to /usr/bin/QTerm, bug #176533.
14 Dec 2006; Michael Sterrett <mr_bones_@gentoo.org> -qterm-0.3.8.ebuild:
clean old, non-modX ebuild
30 Oct 2006; nixnut <nixnut@gentoo.org> qterm-0.4.0.ebuild:
Stable on ppc wrt bug 153216
29 Oct 2006; Andrej Kacian <ticho@gentoo.org> qterm-0.4.0.ebuild:
Stable on x86, bug #153216.
29 Oct 2006; Diego Pettenò <flameeyes@gentoo.org> qterm-0.4.0.ebuild:
Fix DEPEND/RDEPEND.
29 Jul 2006; Ming Zhao <ming@gentoo.org> qterm-0.4.0.ebuild:
fix the broken language files.
*qterm-0.4.0 (28 Jul 2006)
28 Jul 2006; Ming Zhao <ming@gentoo.org> -files/qstring.patch,
-qterm-0.4.0_pre2.ebuild, -qterm-0.4.0_pre3.ebuild, +qterm-0.4.0.ebuild:
Version bumped. Remove beta versions and qstring.patch(integrated by
upstream).
07 Jan 2006; Carsten Lohrke <carlo@gentoo.org> qterm-0.4.0_pre3.ebuild:
QA: need-qt() needs to be called after R/DEPEND.
*qterm-0.4.0_pre3 (02 Jan 2006)
02 Jan 2006; Mamoru KOMACHI <usata@gentoo.org> +qterm-0.4.0_pre3.ebuild:
Version bumped. Thanks to Kraml Liu <kraml.liu@gmail.com> for providing a
patch. This closes bug #116633.
22 Aug 2005; Luis Medinas <metalgod@gentoo.org> +files/qstring.patch,
qterm-0.4.0_pre2.ebuild:
Fix package to work on AMD64. Closes bug #100453.
07 Jul 2005; Caleb Tennis <caleb@gentoo.org> qterm-0.3.8.ebuild:
Fix qt dep
19 Feb 2005; Mamoru KOMACHI <usata@gentoo.org> -qterm-0.4.0_pre1.ebuild,
qterm-0.4.0_pre2.ebuild:
Use kde-function.eclass. This closes bug #80978.
*qterm-0.4.0_pre2 (09 Dec 2004)
09 Dec 2004; Mamoru KOMACHI <usata@gentoo.org> +qterm-0.4.0_pre2.ebuild:
Version bumped.
07 Nov 2004; <pyrania@gentoo.org> qterm-0.3.8.ebuild:
Added arts useflag. Closing bug #62802.
*qterm-0.4.0_pre1 (03 Oct 2004)
03 Oct 2004; Mamoru KOMACHI <usata@gentoo.org> -qterm-0.3.5.ebuild,
-qterm-0.3.6.ebuild, qterm-0.3.8.ebuild, +qterm-0.4.0_pre1.ebuild:
Version bumped. Marked 0.3.8 stable on x86. Removed old ebuilds.
03 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> qterm-0.3.5.ebuild,
qterm-0.3.8.ebuild:
Masked qterm-0.3.5.ebuild and qterm-0.3.8.ebuild stable for ppc
*qterm-0.3.8 (26 Aug 2004)
26 Aug 2004; Mamoru KOMACHI <usata@gentoo.org> qterm-0.3.6.ebuild,
+qterm-0.3.8.ebuild:
Version bumped. Marked previous version stable.
*qterm-0.3.6 (05 Jun 2004)
05 Jun 2004; Mamoru KOMACHI <usata@gentoo.org> qterm-0.3.5.ebuild,
qterm-0.3.6.ebuild:
Version bumped, closing bug #52875. Marked 0.3.5 stable on x86
28 Apr 2004; David Holm <dholm@gentoo.org> qterm-0.3.5.ebuild:
Added to ~ppc.
*qterm-0.3.5 (29 Apr 2004)
29 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> qterm-0.3.5.ebuild:
Initial import. Thanks to <b88901143@ms88.ntu.edu.tw>, Lu Ran
<hephooey@hotmail.com>, Li Zhengang <022021199@fudan.edu.cn> and
Ming Zhao <zhaoming@tsinghua.org.cn>. Closing bug #47487