blob: 1a05cd2d30402ed2727198cdce13932fdb06c363 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit kde5
DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
LICENSE="LGPL-2+ LGPL-2.1+"
KEYWORDS="amd64 ~arm x86"
IUSE="aspell +hunspell nls"
RDEPEND="
$(add_qt_dep qtgui)
$(add_qt_dep qtwidgets)
aspell? ( app-text/aspell )
hunspell? ( app-text/hunspell )
"
DEPEND="${RDEPEND}
nls? ( $(add_qt_dep linguist-tools) )
"
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_find_package aspell ASPELL)
$(cmake-utils_use_find_package hunspell HUNSPELL)
)
kde5_src_configure
}