blob: dc3ad83e203b2a6e8eab3a044c1280a8b504ac72 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=6
inherit qt5-build
DESCRIPTION="The Location module for the Qt5 framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~x86"
fi
IUSE=""
DEPEND="
~dev-qt/qtcore-${PV}
~dev-qt/qtdeclarative-${PV}
~dev-qt/qtgui-${PV}
~dev-qt/qtnetwork-${PV}
~dev-qt/qtpositioning-${PV}
"
RDEPEND="${DEPEND}"
QT5_TARGET_SUBDIRS=(
src/3rdparty
src/location
src/imports/location
src/plugins/geoservices
)