blob: 4ee205dc1ae731c04912ac3b997777854fe41b3f [file] [log] [blame]
DEFINED_PHASES=compile configure install postinst postrm prepare test unpack
DEPEND=>=dev-libs/wayland-1.4.0 ~dev-qt/qtcore-5.6.2 ~dev-qt/qtgui-5.6.2[egl=] media-libs/mesa[egl?] >=x11-libs/libxkbcommon-0.2.0 wayland-compositor? ( qml? ( ~dev-qt/qtdeclarative-5.6.2 ) ) xcomposite? ( x11-libs/libX11 x11-libs/libXcomposite ) dev-lang/perl virtual/pkgconfig test? ( ~dev-qt/qttest-5.6.2 )
DESCRIPTION=Wayland platform plugin for Qt
EAPI=6
HOMEPAGE=https://www.qt.io/
IUSE=egl qml wayland-compositor xcomposite debug test
KEYWORDS=~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86
LICENSE=|| ( LGPL-2.1 LGPL-3 ) FDL-1.3
RDEPEND=>=dev-libs/wayland-1.4.0 ~dev-qt/qtcore-5.6.2 ~dev-qt/qtgui-5.6.2[egl=] media-libs/mesa[egl?] >=x11-libs/libxkbcommon-0.2.0 wayland-compositor? ( qml? ( ~dev-qt/qtdeclarative-5.6.2 ) ) xcomposite? ( x11-libs/libX11 x11-libs/libXcomposite ) dev-qt/qtchooser
RESTRICT=test
SLOT=5/5.6
SRC_URI=https://download.qt.io/official_releases/qt/5.6/5.6.2/submodules/qtwayland-opensource-src-5.6.2.tar.xz
_eclasses_=eutils b83a2420b796f7c6eff682679d08fe25 flag-o-matic 8632fcd33a047954f007dee9a137bdcc multilib 165fc17c38d1b11dac2008280dab6e80 qt5-build c08fc6c5028076eb1a42b7edc5847f42 toolchain-funcs 6198c04daba0e1307bd844df7d37f423 versionator 99ae9d758cbe7cfed19170e7d48f5a9c virtualx 86c9305a59b3e0459e7fbef3a5f30b96
_md5_=bb58f0fc675218d65dae34ddc5755139