blob: 6f2eb3f4876aaae8d79c6ea7eb64bd0f8930750b [file] [log] [blame]
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-backup/duplicity/duplicity-0.6.05.ebuild,v 1.1 2009/10/13 01:53:25 vanquirius Exp $
inherit distutils
DESCRIPTION="duplicity is a secure backup system using gnupg to encrypt data"
HOMEPAGE="http://www.nongnu.org/duplicity/"
SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="s3"
DEPEND=">=dev-lang/python-2.3
>=net-libs/librsync-0.9.6
>=net-ftp/ncftp-3.1.9
app-crypt/gnupg"
RDEPEND="${DEPEND}
>=dev-python/py-gnupg-0.3.2
>=dev-python/pexpect-2.1
s3? ( dev-python/boto )"
src_install() {
distutils_src_install
rm "${D}"/usr/share/doc/${P}/COPYING
}