blob: 0bdbd4aba813feb5244edcb1c371b6ac106c350e [file] [log] [blame]
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/yelp-2.24.0.ebuild,v 1.6 2009/10/29 22:24:45 eva Exp $
inherit gnome2
DESCRIPTION="Help browser for GNOME"
HOMEPAGE="http://www.gnome.org/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~mips ~x86-fbsd"
IUSE="beagle lzma xulrunner"
RDEPEND=">=gnome-base/gconf-2
>=app-text/gnome-doc-utils-0.11.1
>=x11-libs/gtk+-2.10
>=dev-libs/glib-2.16
>=gnome-base/libglade-2
>=gnome-base/libgnome-2.14
>=gnome-base/libgnomeui-2.14
>=dev-libs/libxml2-2.6.5
>=dev-libs/libxslt-1.1.4
>=x11-libs/startup-notification-0.8
>=dev-libs/dbus-glib-0.71
beagle? ( || ( >=dev-libs/libbeagle-0.3.0 =app-misc/beagle-0.2* ) )
!xulrunner? ( =www-client/mozilla-firefox-2* )
xulrunner? ( =net-libs/xulrunner-1.8* )
sys-libs/zlib
app-arch/bzip2
lzma? ( || (
app-arch/xz-utils
app-arch/lzma-utils ) )
>=app-text/rarian-0.7
>=app-text/scrollkeeper-9999"
DEPEND="${RDEPEND}
sys-devel/gettext
>=dev-util/intltool-0.35
>=dev-util/pkgconfig-0.9"
# If eautoreconf:
# gnome-base/gnome-common
DOCS="AUTHORS ChangeLog NEWS README TODO"
src_unpack() {
gnome2_src_unpack
# strip stupid options in configure, see bug #196621
sed -i 's|$AM_CFLAGS -pedantic -ansi|$AM_CFLAGS|' configure || die "sed failed"
}
pkg_setup() {
# FIXME: Add patch to make lzma-utils not automagic and use_enable here
G2CONF="${G2CONF} --enable-man --enable-info"
if use beagle; then
G2CONF="${G2CONF} --with-search=beagle"
else
G2CONF="${G2CONF} --with-search=basic"
fi
if use xulrunner; then
G2CONF="${G2CONF} --with-gecko=xulrunner"
else
G2CONF="${G2CONF} --with-gecko=firefox"
fi
}